[SOLVED] Erase all option missing in 7.32

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Erase all option missing in 7.32

    Embedded studio version 5.70a has an "Erase All" option available in Project Options->J-Link->Erase All

    I do not see this in version 7.32. Is there another location where this option exists in 7.32? Thanks!
  • Hello,

    Thank you for your inquiry.
    Indeed the option went missing between versions.
    It should be reintroduced with the next Embedded Studio update.
    To get a notification when it is available you can subscribe here:

    Out of curiosity, could you elaborate your usecase?
    I assume you are doing some integrity checks in your firmware?
    If that is the case we recommend to work with an image fill value instead of doing a chip erase each time as this will be less tasking on your Flash memory than doing a chip erase every time.
    For more information see here:

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.