[SOLVED] Firmware stucks in OS_PutMailCond()

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [SOLVED] Firmware stucks in OS_PutMailCond()


      we have the problem that our firmware stucks in OS_PutMailCond() after running some hours. I have read following thread where the error description sounds quite similar.

      [SOLVED] Error in OSKern

      We have debugged the problem and found out that in the mailbox struct the pNext pointer of the WaitObj points to itself. Probably this causes the endless loop.

      Does anyone know what the problem could be or how it was solved in the other thread?

      We are using embos 4.16 for Cortex-M3 with gcc toolchain

    • Hello Sebastian,

      your embOS license should be still in support.
      Please get in contact with us and I am pretty sure we can solve that issue quickly.

      Best regards,
      Please read the forum rules before posting.

      Keep in mind, this is *not* a support forum.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support you can contact us via our support system: segger.com/ticket/

      Or you can contact us via e-mail.