[SOLVED] Ambiq Apollo3B not working properly with J-Link

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Ambiq Apollo3B not working properly with J-Link

    - J-Flash V7.66a
    - Windows 10 Home
    - Target MCU: Ambiq Apollo3B(AMA3B1KK-KBR) EVB, SWD, 4000 KHz


    I'm using Ambiq Apollo3B EVB with J-Link.
    After erase device several times, it is no longer operation of erase and programming.
    As far as I know Apollo3B have secure bootloader area in flash.
    Is it possible the J-Link to erase it?

  • According to the log file, connecting to the core seems to work fine.
    No idea why the chips throws an error when J-Link triggers an erase…
    To analyze that, we would need to know what has been programmed into the flash (e.g. you could use the “savebin” command to create a dump)

    There might be a possibility to erase the chip via UART etc. as a fail-safe, but this is something you would need to contact Ambiq about.
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.