[SOLVED] -Werror=format-truncation switching from SEGGER 3.34 to SEGGER 5.50

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] -Werror=format-truncation switching from SEGGER 3.34 to SEGGER 5.50

    I am developing an application. I used SES version 3.34 to develop the project now I am trying to upgrade SES to version 5.50 and I have some compilation errors like this:
    • '%05d' directive output may be truncated writing between 5 and 7 bytes into a region of size 6 [-Werror=format-truncation=]
    that I never had in the 3.34 version.
    Is there a way to fix these compilation errors?

  • Hello,

    Thank you for your inquiry.
    Please note that Embedded Studio V3.34 is out of support and maintenance for many years now and the V5.xx releases are very different.

    A general migration guide from V4 to V5 can be found here:

    For V3 to V5 even more additional steps might be required. But as the difference between V3 and V5 is so large we recommend to create a new project with V5 and add the additional sources manually to your project as that is most likely the more effortless approach.

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.