[SOLVED] SystemView Crashes

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SystemView Crashes

    Hi I am running a Nordic NRF52840 chip and using the Zephyr OS. If I connect SystemView while not much is happening on my board, then it runs fine. But the moment I start doing anything related to BLE the SystemView application just closes on my PC (windows 10). I am connected via a J-Trace Pro cortex M. I can open SystemView right back up, and connect back to my board, but the moment I do anything involving bluetooth your application closes abruptly.

    Another odd thing I see is that one of my ISRs shows a CPU usage much higher than 100%. Not sure if that is related. I will attach a picture of that so you can see.

    Other activity on my board does not seem to cause this crash.

    Any ideas.

    Zephyr has a lot of options related to tracing that I can configure, but I'm not sure if any will help, because I have no idea why your program is crashing.
    • tracing sytem view - context.png

      122.32 kB, 1,920×774, viewed 73 times
  • Hi,
    Thank you for your inquiry.

    There were a couple of these issues fixed in the last version.
    Could you please check if the issue persists in the latest version?
    You can download it here:

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.