[SOLVED] Expected behaviour from 'Threads.setSortByNumber'...

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Expected behaviour from 'Threads.setSortByNumber'...


    In my implementation of an MQX RTOS plug-in for Ozone, I'm wanting to order a table by the values in a 'Priority' column.

    UM08025 suggests that this is achievable using Threads.setSortByNumber(), but I'm unable to get it to function as I'd expect.

    I'm initialising the table as shown below:

    But the sorting of the "Priority" column appears unaffected.

    Have I misunderstood the purpose of Threads.setSortByNumber(), or am I doing something wrong?

    I'm using Ozone V3.22a.


  • Hello,

    Thank you for your inquiry.
    This was a bug in the plugin window where the sorting was not working correctly.
    Should be fixed with the next Ozone update.
    You can subscribe here to receive a notification once the new version is available:

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.