KarelDeKlein Community Member

  • Member since Jul 13th 2020
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • KarelDeKlein -

    Replied to the thread Problems communicating with RTT after flashing a device.

    Post
    Hi Fabian, We have tested your example, it works great and I think we have found the problem. After looking more in our production software, we find out the production software sets the first telnet port to 19022; "-rtttelnetport 19022". We think this…
  • KarelDeKlein -

    Replied to the thread Problems communicating with RTT after flashing a device.

    Post
    Hi Fabian, No, unfortunately the "exit" at the end does not fix the issue. Kind regards, Karel
  • KarelDeKlein -

    Replied to the thread Problems communicating with RTT after flashing a device.

    Post
    Hi Fabian, The issue occurs when flashing the PIC32 with JLink, PIC32 flash with jflash is not possible with the current version, V6.80d. the situation is: MCU1 = EFR32FG14PxxxF256 MCU2 = PIC32MX440F128L We do the following steps: 1) JFlash to flash…
  • KarelDeKlein -

    Replied to the thread Problems communicating with RTT after flashing a device.

    Post
    Hi Fabian, We connect to telnet by first connecting the device with Jlink, using the following command: Source Code (1 line) when connected to jlink, we can setup a telnet communication to the address: localhost:19021. this works most of the time, it…
  • KarelDeKlein -

    Posted the thread Problems communicating with RTT after flashing a device.

    Thread
    Hello everyone, I cannot connect with Segger's RTT to my device directly after flashing another device, using the same jlink adapter. I hope somebody can help me with this. We are creating a production tool to flash and test a product with 2…