zamniah Community Member

  • Member since Mar 9th 2020
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • zamniah -

    Replied to the thread Jlink Script.

    Post
    There is loadfile which supports hex files, you could probably load it with those two commands. I use two-part firmware which is loaded with loadbin like this: Shell-Script (8 lines) If you need to specify addresses, you probably need to convert the…
  • zamniah -

    Replied to the thread [SOLVED] Jtrace + SWO Pin + STM32CubeIDE clock sliding - ITM trace.

    Post
    OK, solved this. Apparently STM32 Cube IDE sets prescalers, etc. wrong and SWOViewer acts weird. I got it working via gdb scripts from orbuculum, this enables SWO ITM PC sampling, core clock 168 MHz, SWO baud rate 2Mbaud. Commands for GDB: Source Code…
  • zamniah -

    Replied to the thread Ozone stuck on "resetting device".

    Post
    Quote from SEGGER - Nino: “That is not correct and the issue you are describing here is due to an incorrect project setup. For more information see here: wiki.segger.com/Debug_on_a_Target_with_Bootloader So the reset behaviour is always the same. The…
  • zamniah -

    Replied to the thread Ozone stuck on "resetting device".

    Post
    I had issues with resetting device from Ozone, it uses different method than JLink commander's reset or "monitor reset" via gdb (perhaps it just jumps to reset vector instead of doing device reset?) AFAIK there is no possibility to change resetting…
  • zamniah -

    Posted the thread [SOLVED] Jtrace + SWO Pin + STM32CubeIDE clock sliding - ITM trace.

    Thread
    Since either my JTrace don't work correctly wtih STM32 board: The given reference board is STM32507VG (which is included in JTrace port. The program was micropython default build for STM32F4DISCOVERY. Since my STM32f427 board doesn't work well with…