Nikosant03 Community Member

  • Member since Feb 24th 2020
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Nikosant03 -

    Replied to the thread [SOLVED] How to read warnings on Segger IDE.

    Post
    Hi Fabian, Ok, I figured out that there was actually an issue on the firmware, that's the warning. The warning was cleared as the issue was fixed. But still some times I've got warnings and when I hover the mouse above the warning symbol there is no pop…
  • Nikosant03 -

    Posted the thread [SOLVED] How to read warnings on Segger IDE.

    Thread
    Hi everyone, There are times that I can see warnings on SEGGER IDE but I cannot read the context of the warning. For example, at image attached, there is a warning but even if I hover the mouse over the warning there isn't any pop up message. This is…
  • Nikosant03 -

    Replied to the thread [SOLVED] How to use breakpoints.

    Post
    Thank you Fabian, You can close this thread.
  • Nikosant03 -

    Replied to the thread [SOLVED] How to use breakpoints.

    Post
    Ok I figured out what was going wrong, I was compiling in release mode :) After switching to debugging mode everything was fixed!! I lost two hours of searching yesterday [img]https://cboard.cprogramming.com/images/smilies/biggrin.png[/img] but that was…
  • Nikosant03 -

    Replied to the thread [SOLVED] How to use breakpoints.

    Post
    Hi everyone, I am trying to learn the basics of debugging using SEGGER. I am using a very simple blinky example to start learning debugging. I have declare and initialize two variables x & y. When I run the debugger and use the "watch" window to monitor…
  • Nikosant03 -

    Posted the thread [SOLVED] How to use breakpoints.

    Thread
    Ok I figured out what was going wrong, I was compiling in release mode :) After switching to debugging mode everything was fixed!! I lost two hours of searching yesterday [img]https://cboard.cprogramming.com/images/smilies/biggrin.png[/img] but that was…
  • Hi Nino, You're right!! While I am adding variables in non_init() section, the end address and the size are modified accordingly!! I learned lot of things, thanks!! Nick
  • Thank you very much Nino, it works perfect!! However I tried the same approach to find the __non_init_end__ address and the __non_init_size__ but the __non_init_size__ = 0x0 The address range of .non_init section is dynamic? So, I suppose that there…
  • Hi everyone, I am new to this and I need your advice and help. I am using Segger IDE to develop an aplication along with Nordic's SDK. I have to retain the value of one variable and do not be initialized after system reset. In order to achieve this I…
  • Nikosant03 -

    Replied to the thread [SOLVED] Getting started with J-Link EDU mini.

    Post
    Thank you for your advice Fabian, At the moment we have the nRF52840 DK with OB SEGGER J-Link for company use. I will keep the J-Link EDU mini for personal/hobbyist at home usage. Best Regards Nick
  • Nikosant03 -

    Replied to the thread [SOLVED] Getting started with J-Link EDU mini.

    Post
    Thank you Fabian for you responce, Following the J-Link connection guide I figured out that I was using (didn't notice) a mini USB cable that was intended for charging only (no data transfer). Now everything works fine. By the way, I've bought the…
  • Nikosant03 -

    Posted the thread [SOLVED] Getting started with J-Link EDU mini.

    Thread
    Hi everyone, I've purchached the J-Link EDU mini because I needed for flashing the nRF52840 module. I am new here and I need some guidance. First of all I suppose that I have to update the firmware on the J-Link isn't it? So, I downloaded the J-Link…