satheesh Beginner

  • Member since Jan 13th 2020
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • satheesh -

    Replied to the thread keil freezes and also RTT viewer couldnot establish connection with target.

    Post
    Hi Fabian, 1) I did not set my connections to "existing session'' + "auto reconnect". refer to the below image for my current settings forum.segger.com/index.php/Att…6ac732879b71f313c9c1078a9 2) when I tried to use "existing session" + "auto…
  • satheesh -

    Replied to the thread keil freezes and also RTT viewer couldnot establish connection with target.

    Post
    Hi Fabian, I have updated the J-link software including DLL. But still the problem persists and after update the freezing of keil is happening more often compared to earlier version of J-link software 1) I am using the evaluation board which is…
  • Hi, I am working on ARM Cortex M4 development board provided by Vorago technologies. I am using keil IDE and connecting the target via J-link OB. At some instances of flashing the program/Entering into debug mode, the keil is becoming unresponsive.…
  • satheesh -

    Replied to the thread Trace HW not present - ARM cortex M4.

    Post
    Hi Nino, Thank you for the solution. Will the external J-*link or J-trace PRO be helpful to get trace features even if the Cortex-M4F does not have ITM, DWT and TPIU ports? Regards, Satheesh
  • satheesh -

    Posted the thread No Cortex-M SW Device found.

    Thread
    Hi, I am working on ARM Cortex M4 development board provided by Vorago technologies. I am using keil IDE with "debug Jlink/J-trace Cortex". In the driver setup setting, there is no IDCODE getting detected and when I try to flash there is an error…
  • satheesh -

    Posted the thread Trace HW not present - ARM cortex M4.

    Thread
    Hi, I am working on ARM Cortex M4 development board provided by Vorago technologies. I am using keil IDE with Jlink/J-trace Cortex. When I enable the "Trace"(look in attachement for settings), the debugging session is getting terminated with an error …
  • satheesh -

    Replied to the thread Error when added segger RTT to a Keil project.

    Post
    Hi Nino, Thanks for the suggestion. I made the changes in ''Run time environment'. After making the additional changes at 'Public const' and '_sys_exit' (can refer to attachments), still i am getting the follwing errors *** Using Compiler 'V5.06 update…
  • satheesh -

    Posted the thread Error when added segger RTT to a Keil project.

    Thread
    Hi, I am working on ARM Cortex M4 processor with Keil MDK. While compiling the project, I am getting the following error. From the Error I understood that there is a multiple definition and I need to get rid of one. Can someone please tell me what is the…