SEGGER - Fabian Administrator

  • Member since Aug 30th 2019
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Fabian -

    Replied to the thread Save dialog when exiting J-Flash.

    Post
    Hi, Thank you for your inquiry. Currently, there is no way to prevent this from happening. I will raise this as a topic on our next internal meeting and come back to you as soon as I have news regarding this. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] RTTViewer skips lines in logging when MCU is reset.

    Post
    Hi, I can see that you also contacted us via the Support Ticket System. I already answered you there. We will close this thread, to keep communication to one channel. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread CPU TAP NOT FOUND.

    Post
    Hi, Thank you for your inquiry. Some additional information would be useful: 1) What is the exact name of the device you are trying to connect to? 2) Are you working on an evaluation board or custom hardware. If evaluation board, which one? Best…
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] QSPI indirect flashing SAM V71 + ISSI IS25LP064.

    Post
    Hi K, Thank you for your inquiry. Could you please open a ticket in our support ticket system for that? You can find the link below in my signature. Information we would require in the ticket: 1) Reference of this thread by link. 2) Pins you are using…
  • SEGGER - Fabian -

    Replied to the thread Subsequent Connections to RP2040 Fail.

    Post
    Hi, We did not forget about this. ;) The problem here is, that we currently have a lot of projects with their timeline approaching. This issue will be addressed as soon as possible, however, there are currently no resources available for this. We will…
  • SEGGER - Fabian -

    Replied to the thread J-Link Debug Fails.

    Post
    Hi, From the logfile I can tell that you are using J-Link software that is actually pretty old. Could you please update the J-Link Software? You can find the latest version of the J-Link Software Pack here:
  • SEGGER - Fabian -

    Replied to the thread segmentation fault on linux ARM.

    Post
    Hi Guillaume, Could you please provide us with a reproducer for this? Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread J-Link Debug Fails.

    Post
    Hi, Thank you for your inquiry. There is no such issue known to us. At first glance, this does not necessarily look like a J-Link related issue. What Device are you trying to debug exactly? Could you please send us a J-Link log file? How to enable:
  • Hi, Thank you for your inquiry. We are not aware of any issues related to the STM32F1 series and JTAG. I just gave this a quick try and it seems to be working without any issues on an STM32F10X-128K-EVAL board (STM32F103V8):
  • SEGGER - Fabian -

    Replied to the thread Program address offset in JFlash.

    Post
    Hi Priya, Thank you for your inquiry. I am sorry, but I do not quite understand what you are trying to achieve. Could you please explain in more detail? In general: 1) .bin files do not contain any address information, so when opening them in J-Flash…
  • Hi, Good to hear that you were able to resolve the issue. We will close this thread now. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread Raspberry Pi Pico RP2040 - Cortex-M HardFault Exception.

    Post
    Hi, We are not aware of such an issue. You can find an example blinky project for the RP2040 here: wiki.segger.com/Raspberry_Pi_Pico#Example_Projects It should be working out of the box for Ozone / Embedded Studio. Could you please give that one a…
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] nRESET as Input/Output.

    Post
    Hi, As this inquiry is resolved, we will close this thread now. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread J-Link - making changes through J-Link Control Panel persistent.

    Post
    Hi, Thank you for your inquiry. Yes this is possible by using a J-Link Command string: wiki.segger.com/J-Link_Command_Strings#SetCompareMode How you can use them is also explained in the same article:
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] TMS470 on J-link with J-Flash.

    Post
    Hi, Sorry for the delay in response. If everything is working correctly, flash can be written with the w* commands. As Alex already said however, this might not be the case for your device, as it is not officially supported and might be different…
  • SEGGER - Fabian -

    Replied to the thread JLinkExe tab completion does not work on Ubuntu.

    Post
    Hi, Sorry for the delay in response. We are able to reproduce this behavior. We will look into this as soon as possible. Unfortunately, we are currently very busy with multiple pressing projects, so it might take a while until we are able to resolve…
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] J-Link EDU Mini.

    Post
    Hi, Sorry for the delay in response. Somehow this slipped under the table. If we understand you correctly the SWDIO GPIO lane was damaged/destroyed. This should not be possible by simply connecting it to ground. Possible causes could be: - 5V+ current…
  • Hi, Sorry for the delay in response. We have not forgotten about this. Unfortunately, we do not have any resources available to look into this, but we will do so as soon as possible. We have some high priority projects with upcoming deadlines we have to…
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] CMSIS-DAP.

    Post
    Hi, Unfortunately, not. The J-Trace would be listed otherwise. As this inquiry is solved now, I will close this thread. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] CMSIS-DAP.

    Post
    Hi everyone, You would need a J-Link of the latest generation to make use of this feature. I forwarded this to our web team so they add this information to the website. The models with CMSIS support are: - J-Link EDU/BASE/PLUS V11 - J-Link ULTRA+ V5 -…