SEGGER - Fabian Administrator

  • Member since Aug 30th 2019
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Fabian -

    Replied to the thread [SOLVED] Unable to upgrade firmware on J-Link Edu Mini.

    Post
    Hi, You are welcome! Good to hear that everything is working as expected now. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread S32K144 d-flash programming failure.

    Post
    Hi Victor, Glad to hear that you found the source for the issue. So if I understand you correctly, this is resolved now and we can consider this thread as closed? Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] STM32H750 - Writing DTCM.

    Post
    Hi Sébastien, No worries. :) We will consider this thread as closed now. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread S32K144 d-flash programming failure.

    Post
    Hi Victor, Thank you for your inquiry. It looks like you are writing to 0x00000000, not to 0x10000000. Are you trying to download a .bin file? If so, you will have to add the starting address of where to download the file as well: Syntax: loadfile…
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] STM32H750 - Writing DTCM.

    Post
    Hi, Thank you for your inquiry. I think there is a misunderstanding here. J-Flash is not able/supposed to program RAM. Also, what ever is written to the RAM, will be lost after reset anyway. It looks to me like you have a memory dump (.hex-file) and…
  • SEGGER - Fabian -

    Replied to the thread SAM-ICE works, but J-Link EDU does not.

    Post
    Hi, Thank you for your inquiry. Such an issue is not known to us. Could you please tell us which XPlained Pro board you are referring to? There are multiple boards with that name. Could you please send us a screenshot of the full J-Link Commander…
  • SEGGER - Fabian -

    Replied to the thread STM32G431CB / Flash issue.

    Post
    Hi Sébastien, Thank you for your inquiry. We are analyzing an issue regarding the STM32G431-series right now. What you are experiencing seems to be connected to this issue. We will come back to you as soon as we have news about this. Best…
  • SEGGER - Fabian -

    Replied to the thread Segger RTT no output when using Jlink-Remote Server.

    Post
    Hi, Thank you for your inquiry. Such an issue is not known to us. Could you please tell answer the following questions: 1) What device are you trying to get data from? 2) Do you get RTT output, when using a local setup (using RTT Viewer on the same PC…
  • SEGGER - Fabian -

    Replied to the thread JLINK Unspecified Error -1.

    Post
    Hi, Thank you for your inquiry. Such an issue is not known to us. Does this behavior also appear when using the newest J-Link Software and Documentation Pack version? You can download it here: If so, could you please verify if the target was…
  • SEGGER - Fabian -

    Replied to the thread J-Flash - Failed to erase chip.

    Post
    Hi, Thank you for your inquiry. Such an issue is not known to us. Do you use custom hardware or an evaluation board? In the latter case which one? If custom hardware, do you experience the same problem on an evaluation board? Could you please send us a…
  • SEGGER - Fabian -

    Replied to the thread stm32g431 J-Link error "Failed to measure CPU clock frequency".

    Post
    Hi Pawel, Sorry for the delay in response. We were able to reproduce the issue and are looking into it right now. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] J-Link Base troubles to connect to CYW43907.

    Post
    Hi, Thank you for your inquiry. We tried to reproduce the issue. On the BCM43907 / CYW43907 WICED kit everything is working as expected. As we also answered your questions in our support ticket system we will consider this case as closed now. Best…
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] Trouble Connecting to Traveo S6J334EJT.

    Post
    Hi Mark, Thank you for your inquiry. Since you contacted us via Support System, we will close this thread to make sure no information is lost between the channels. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread Error while reading netx90 flash.

    Post
    Hi Johannes, Sorry for the delay in response. We recently had a customer who had a similar problem. According to him the problem was caused by some switches on the evaluation board, which were not set correctly. Could you please check this? Did you…
  • SEGGER - Fabian -

    Replied to the thread STM32H743 DBGMCU register reads as zero when using ETF-Trace.

    Post
    Hi Thomas, Thank you for your inquiry and sorry for the delay in response. We are able to reproduce this. Thank you for making this known to us. We will see if we can find a solution for this that works out of the box. As a work around you could write…
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] Unable to upgrade firmware on J-Link Edu Mini.

    Post
    Hi, Yes, you can also reset the config area via J-Link Commander: Please connect to the J-Link and type "resetconf" (without quotations). After doing so: Is it now possible to connect to the J-Link EDU mini via J-Link Configurator? Best regards, Fabian…
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] Feature Request RTT: SEGGER_RTT_Peek().

    Post
    Hi Henry, Thank you for your feature suggestion. I will forward this to the corresponding department and we will discuss this internally. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] Unable to upgrade firmware on J-Link Edu Mini.

    Post
    Hi, Did the reset of the config area work though? Just to eliminate the possibility that this problem is connected to the J-Link Configurator: Could you please try to update the firmware via the J-Link Commander? Just open the J-Link Commander and…
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] STM32WB50 support.

    Post
    Hi Robson, I am happy to hear that you are up and running again. We will consider this case as closed now. Best regards Fabian
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] STM32WB50 support.

    Post
    Hi Robson, It seems that the WB50 is compatible to the WB55 devices. Unfortunately, there is no reference manual and no evaluation board available for this device. Therefore we see the following 3 options: - If the devices are indeed compatible, you…