SEGGER - Fabian Administrator

  • Member since Aug 30th 2019
Last Activity
, Reading thread [FRDM-KE15Z] Jlink disabling Wdog operation issue

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Fabian -

    Replied to the thread [FRDM-KE15Z] Jlink disabling Wdog operation issue.

    Post
    Hi Zeliang, There is no need to replace any files. The files I sent you are supposed to work out of the box, and they do on my side. Does it work if you do not copy any files but just extract them to a separate folder and start the JLink.exe? Since the…
  • SEGGER - Fabian -

    Replied to the thread [FRDM-KE15Z] Jlink disabling Wdog operation issue.

    Post
    Hi Zeliang, I sent it to you inside of this forum as a private message. You can access it via the "Conversations" button on the most top of this page. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread [FRDM-KE15Z] Jlink disabling Wdog operation issue.

    Post
    Hi Zelian, I sent you a link to a preliminary version which does write the UPDATE bit to 1 via private message. Could you try if everything works as expected with this version? Please do not share this file with any third parties. The file is provided…
  • SEGGER - Fabian -

    Replied to the thread [FRDM-KE15Z] Jlink disabling Wdog operation issue.

    Post
    Hi Zeliang, We are looking into this as soon as possible. I will keep you posted. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread RTT Viewer font is tiny on 4k monitor v6.70+.

    Post
    Hi Andre, You are welcome! We will consider this thread as closed now. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread RTT Viewer font is tiny on 4k monitor v6.70+.

    Post
    Hi Andre, Thank you for making this known to us. We found the root cause of the issue and fixed it. The fix will be part of the next patched release (planned for the end of this week) of the J-Link Software and Documentation Pack, available for download…
  • SEGGER - Fabian -

    Replied to the thread [FRDM-KE15Z] Jlink disabling Wdog operation issue.

    Post
    Hi Zelian, I just checked on that. The behavior is intended. Disabling the watch dog is required to debug this device. Not doing so can lead to problems for the debug session. The WDOG is not supposed to be active while debugging. Does this answer your…
  • SEGGER - Fabian -

    Replied to the thread How do I flash SOC without erasing first.

    Post
    Hi, Thank you for your inquiry. First, the J-Link Commander (JLinkExe) doese not erase the entire ROM before flashing, but only the required sectors the data is flashed to. Regarding your question: It is possible to configure the read-modify-write…
  • SEGGER - Fabian -

    Replied to the thread What J-link unit is the Flasher Portable PLUS equivalent to?.

    Post
    Hi, Thank you for your inquiry. The short answer is: None. Concept-wise, Flasher Portable Plus and J-Link are two very different things. The Flasher is optimized for production and the J-Link is optimized for debugging and therefore it is hard to…
  • SEGGER - Fabian -

    Replied to the thread Unable to flash a TI LaunchPad CC2652R1FRGZ.

    Post
    Hi Torsten, Thank you for your inquiry. Could you please provide us with a photo of your setup (jumper settings, cable connections, etc.)? Could you please follow the troubleshooting article on the page linked below and send us a screenshot of the…
  • Hi, We received your inquiry in our support system as well and will answer you there. To make sure no information is duplicated and to minimize the work load on our side, we will close this thread now. Please try to keep communication to one channel in…
  • Hi, I reviewed the command lines you are passing to the J-Link GDBServer again. You are passing "-ir", which basically initializes most registers to "0". This is also the reason why a reset prevents this HardFault, because after a reset, the registers…
  • SEGGER - Fabian -

    Replied to the thread QSPI speed in bundled STM32L496G_Disco OFL?.

    Post
    Hi, Thank you for your inquiry. I sent you the sources via PM. Please do not share this file with any third parties. The file is provided as-is without claim for support. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread Jlink call in Jenkins doesnt exit.

    Post
    Hi Joe, Thank you for your inquiry. As lines 10, 52-55 indicate, it seems like the J-Link commander cannot comprehend the commands you are trying to issue. Therefore, the J-Link Commander does not do anything but connect to the device and therefore also…
  • SEGGER - Fabian -

    Replied to the thread GDBServer : FreeRTOS thread count is unreasonably big ...

    Post
    Hi, We will be looking into this as soon as possible. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread Unwanted SIGTRAP when adding breakpoints on Linux.

    Post
    Hi, Thank you for your inquiry. Such an issue is not known to us. I assume you are using the same Hardware as in the other thread you created. Correct? Could you please also send us a J-Link log file of this session? Best regards, Fabian
  • Hi, Thank you for your inquiry. Such an issue is not known to us. 1) Do you use custom hardware or an evaluation board? In the latter case which one? 1.1) If custom hardware, do you experience the same problem on an evaluation board? 2) Could you please…
  • SEGGER - Fabian -

    Replied to the thread JLink -NoGui 1 "Unknown command line option -NoGui.".

    Post
    Hi, Thank you for your inquiry. The "-NoGui 1" command line is not yet supported. It will be part of the next beta release planned for Friday. I added a note to the Wiki-page. Best regards, Fabian
  • SEGGER - Fabian -

    Replied to the thread JLinkExe unwanted GUI.

    Post
    Hi, The feature will be part of the next beta release planned for Friday. I will send you a link with a preliminary version for testing purposes via PM. Please do not share this Version with any third parties. The file is provided as-is without claim…
  • SEGGER - Fabian -

    Replied to the thread [SOLVED] IMXRT1020 Segger RTT Auto Search not working.

    Post
    Hi Stefan, Good to hear that you are up and running again. I will suggest this on our next internal meeting. We will consider this thread as closed. Best regards, Fabian