AudreyD Beginner

  • Member since Jan 23rd 2019
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Martin, Since it appears that the problem comes from our application, I will now use the support_embos email. Best regards, Audrey
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Martin, We have observe the same problem on another run but this time, the application didn't crashed. I attached the associated screenshot. It appears that, this time, when the OS_tick interrupt is finiched, no other change task is required. We return…
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Here is a screenshot of the problem :
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Hi Martin, We have modified the link file to store the USTACK in internal memory, so that the application can start using USTACK, and not ISTACK as it was before. Now, the "post mortelm mode" works perfectly, but we still have a problem... Since we…
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Hi Martin, Yes, this has solved the observed problem. We are now able to use SystemView in "live mode" and it works correctly. But now, to understand our bug, we would like to use SystemView in "Post mortem mode". We have put the associated flag to 1,…
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Hi Martin, Yes, you're right. embOSView is working fine even if we put all code in external memory (except stacks). However, we have a problem by using SystemView. SystemView works correctly when all the code is in internal memory but, when we put all…
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Hi all, embOS v5.02a is now implemented in our software. We are trying to use embOSView but we get some troubles. With our software project, it works only when we reset the debug session, while it works very well using our board, but having loaded the…
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Hello Til, > in my understanding you are using the embOS RX CCRX sources with the IAR EWRX compiler and implement the necessary changes by yourself instead of licensing embOS RX IAR, right? Yes, you are right. > This will not happen since only the…
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Martin, Here are some news. We have performed other tests and we were actually wrong concerning the U bit to 0. It is well set to 1 but however there is a bug in embOS. This bug appears when two interrupts (nested or with different priorities) run at…
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Hi Martin, I come back to you since the order has been processed. We have used the "Trace" tool from IAR and we get the following behavior : 1. One task was running and it is now waiting for a message in its mailbox 2. embOS calls "OS_Deactivated()"…
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Martin, I perfectly understand. I will talk to my boss about that point. I will come back to you later on. Best regards, Audrey
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Hi Martin, Our licence for embOS is [1.34.04.07] RX CCRX but I confirm that I use IAR. We have adapted embOs to work with IAR because E2 Studio was not going to work for us. Best regards, Audrey
  • AudreyD -

    Replied to the thread Error 118 : OS_ERR_INTERNAL.

    Post
    Martin, Thanks a lot for your response ! This guides us through our investigation. This error appears randomly, sometimes after 2 hours of run, sometimes after 7 days. However, it appears every time. I'm not sure that providing the sources will help…
  • AudreyD -

    Posted the thread Error 118 : OS_ERR_INTERNAL.

    Thread
    Hello all, I use embOS v4.02a, in OS_DEBUG mode, and my application stops line 9 : C Source Code (11 lines) In documentation it is written that this error appears when : OS_ChangeTask() called without Region Counter set (or other internal error). In…