smithron99 Beginner

  • Member since Jan 6th 2019
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • smithron99 -

    Replied to the thread Problems with virtual functions.

    Post
    Looks like that was it. I reduced the base class ctor to straight member initializations and then called derived.init() explicitly after the class is constructed. All good. Maybe this is something common I used to know? Some twinge of familiarity...
  • smithron99 -

    Replied to the thread Problems with virtual functions.

    Post
    If the debugger is telling the truth, then it looks like the vtable is fully populated, but not correct (see attached image). Not sure why the destructor is showing at both offsets [0] and [1]. Could the problem be that this is happening in the base…
  • smithron99 -

    Replied to the thread Problems with virtual functions.

    Post
    Hmmm. A few odd things: 1. When I went into settings I found I already had the linker set to "GNU" 2. When I re-enabled rtti, the undefined reference was gone. 3. Virtual functions still aren't working properly. When the derived class is constructed, I…
  • smithron99 -

    Posted the thread Problems with virtual functions.

    Thread
    Hello, I'm working with nRF SDK 14.2 and the NRF52832 Dev kit, developing in C++. I have a base class with a few virtual functions and a derived class that I'm using. The code compiled, linked and flashed fine, but in debugging found that the virtual…