dzabel Beginner

  • Member since Nov 6th 2018
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • dzabel -

    Replied to the thread [SOLVED] SFR display not working for register arrays of nRF52840.

    Post
    Hi Nino, thank you for spending all the time on this issue! It seems I had a different version of the nRF CPU Support Package installed. It looked different from your image, for example, it had a subfolder "Registers", but lacked the register files you…
  • dzabel -

    Replied to the thread [SOLVED] SFR display not working for register arrays of nRF52840.

    Post
    Hi Nino, I am using the nRF52840 DK hardware. Therefore, I have used the projects for target pca10056 with s140 softdevice. I tried the project ble_app_hrs, ble_app_hrs_freertos, blinky_pca10056 and some more. The unmodified setting for the svd file is…
  • dzabel -

    Replied to the thread [SOLVED] SFR display not working for register arrays of nRF52840.

    Post
    Hi Nino, Just to give you an update: see here Discussion with Nordic. 'The register array display works, if I replace hex numbers by decimal numbers in the <dim> and <dimIncrement> elements of the SVD files. According to the Nordic support engineer, they…
  • dzabel -

    Replied to the thread [SOLVED] SFR display not working for register arrays of nRF52840.

    Post
    Hi Nino, that was just the question: is it an SES issue or an incorrect SVD file? To decide this, I would need a specification of the supported SVD file format. I have now put the very same question to Nordic. I hope they don't redirect me…
  • dzabel -

    Posted the thread [SOLVED] SFR display not working for register arrays of nRF52840.

    Thread
    Hi, I am running Segger Embedded Studio (4.10a) to get used to the Nordic DK for the nRF52840. Now I have found, that the register display seems not to be able to show some of the SFRs. For example, if I activate the UICR group, I get the following…