Gossamer Beginner

  • Member since Apr 23rd 2018
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Gossamer -

    Replied to the thread Register definition file causing issues.

    Post
    Hi, Attached is the svd file. Issue happens as soon as I attach the svd file and do the first debugging over SWD. I dont even enable any of the peripherals in the register viewer. Didnt try JTAG, as I dont have compatible board. Removing the svd file,…
  • Gossamer -

    Posted the thread Register definition file causing issues.

    Thread
    I am using embedded studio v4.12. After loading the LPC5410x.svd file, debugging slows down by factor of 1000 (maybe more). Each "step over" takes 2-3 minutes instead of 1second. This same file worked fine in version 3.42b, so I wouldnt say its corrupted…
  • Gossamer -

    Replied to the thread Debugger code upload clear flash ?.

    Post
    I made a little test application, and I was able to reproduce the behaviour. After better observation, problem seems to be in Memory viewer rather than debugger clearing the code. What I did is following: Source Code (3 lines) This works like a charm.…
  • Gossamer -

    Posted the thread Debugger code upload clear flash ?.

    Thread
    I have code that I am debugging now and it is around 8kbyte large and it sits in sector 0 (start location at 0x0000). According to the user manual each sector is 32kB. I have pushed some custom data to Flash at position 0x8000 (sector 1), but after…
  • Gossamer -

    Posted the thread VCS integration with GIT error.

    Thread
    I have issues using VCS on macos with GIT. I have local repository (cloned from the server), which I can open with GIT client (Tower). In Embedded studio, I have configured the git executable "/usr/bin/git" and preferred username and email. When I load…