SEGGER - Nino Administrator

  • Member since Jan 2nd 2017
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Nino -

    Replied to the thread Library Linking issue.

    Post
    Hello, Thank you for your inquiry. How do you set the library in your project? Are there any additional library header files that need to be taken account of? If yes, did you make sure their path is set in user include directories? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread SYSTEM_VIEW recording with simulation ports..

    Post
    Hello Manish, Thank you for your inquiry. What do you mean with windows simulator, could you elaborate? For SystemView to work you need a J-Link and target hardware that is supported by J-Link. Not sure how you plan on simulating our debug probe. Best…
  • SEGGER - Nino -

    Replied to the thread Undefined reference to Segger APIs after integrating SystemView files.

    Post
    Hello, Did you read the provided Wiki article? Did you download the provided example project? It was made with FreeRTOS V10.4.3. It was tested and works. If you follow the steps and your resulting project looks like the example project SystemView will…
  • SEGGER - Nino -

    Replied to the thread Stop Debug Session (Shift-F5) leaving CPU halted?.

    Post
    Hello, Thank you for your inquiry. This is expected behaviour as control over the device is only given during the debug session. When leaving the debug session we leave the application running to enable setups where you would attach to certain code…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] J-Link EDU Debug Probe with Ozone and SystemView.

    Post
    Hi, Quote from xtrem: “- This is the schematic of the JTAG connector of my board ” On first glance looks correct. Quote from xtrem: “- What version of J-Link EDU includes/works with license SFL ? ” All of them. Quote from xtrem: “- These…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Run Time/s Context.

    Post
    Hello Kevin, Thank you for your inquiry. This is indeed a display bug in SystemView and will be fixed with the next verison. To get notified when the release is available you can subscribe here: segger.com/notification/subscribe.php?prodid=7,204 Best…
  • SEGGER - Nino -

    Replied to the thread Undefined reference to Segger APIs after integrating SystemView files.

    Post
    Hello, Thank you for your inquiry. The guide for the SystemView integration is pretty straightforward: wiki.segger.com/FreeRTOS_with_…View#System_Configuration We recommend to use the example projects from the Wiki for reference. If your project setup…
  • Hello, Thank you for your inquiry. Most likely the patch file does not fit the folder structure used in your project. In that case we recommend to patch manually without a patching tool. There are not that many changes necessary. Quote from faulkner:…
  • SEGGER - Nino -

    Replied to the thread Build problem at STM32F4 Cube Package 1.26.0.

    Post
    Hi, Thank you for your inquiry. Not all FreeRTOS versions are backwards compatible. So it is possible that if you update your FreeRTOS Sources SystemView will no longer work. Which is why we supply different patch files for different FreeRTOS…
  • SEGGER - Nino -

    Replied to the thread essential to compile and download to the dev board.

    Post
    Hi, Generally a build and debug (F7+F5) is the right approach if you change only a source file or similar. But if you are changing project settings, include paths, other linker related changes, then we recommend a Rebuild (Alt+F7). Quote from MUETA:…
  • SEGGER - Nino -

    Replied to the thread Ozone remote debugging.

    Post
    Hello, Thank you for your inquiry. The error message usually indicates that a J-Link feature is utilized that is not implemented for remote server yet. Could you provide some additional info of your setup? What is the S/N of your J-Link? With what…
  • SEGGER - Nino -

    Replied to the thread Vendor specific .svd file still not fetched when opening .jdebug file.

    Post
    Hello, Thank you for your inquiry. How are you adding the svd file to your project exactly? Could you share your .jdebug file that you try to reopen for reference? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Ozone 3.24a doesn't show variables.

    Post
    Hello, Thank you for your inquiry. Was this working for you with Ozone V3.2x versions? What target device are you debugging exactly? Could you provide a reproduction project for an eval board that would run out of the box + reproduction steps? Best…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Debug session quits by itself.

    Post
    Hello, We received this inquiry via our support system in parallel so this thread will be closed now. The solution was that the target application was using a __WFI instruction during debug which caused this issue. Generally we do not recommend to try…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] J-Link EDU Debug Probe with Ozone and SystemView.

    Post
    Hello, Thank you for your inquiry. 1: Yes a J-Link EDU will work with Ozone and any of the other software we provide. All of our software is now under the SFL license where generally private or educational usage is fair.
  • SEGGER - Nino -

    Replied to the thread jlink reset TRCENA in disconnect.

    Post
    Hello, Thank you for your inquiry. What exactly are you planning to do? Usually target application code should not need to access debug registers. If you now change the debug register settings behind Embedded Studios back it is possible that they may be…
  • SEGGER - Nino -

    Replied to the thread Ozone 3.23 - 3.24a not working in OSX.

    Post
    Hi appulin, Thank you for the inquiry. The issue is reproducible. We are looking into it. Quote from danngreen: “Does the Ozone development team plan to put effort into improving the Mac OS version of Ozone? If not, we would like to know so we can…
  • SEGGER - Nino -

    Replied to the thread Ozone 3.24b compatibility with JLink remote server.

    Post
    Hello, Thank you for your inquiry. Generally we recommend to keep the versions in sync when possible. However we always try to keep things backwards compatible so a new Client version should always work with an older J-Link DLL. It also works the other…
  • SEGGER - Nino -

    Replied to the thread Remotely control Ozone.

    Post
    Hello, Thank you for your inquiry. Yes you can start Ozone via command line. So you can use it e.g. within your Python script. To automate the Ozone GUI actions Ozone has its own scripting which is done in the Ozone project file directly. Both is…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] J-trace for AM57xx.

    Post
    Hello, J-Trace Pro Cortex also has Cortex-A15 debug support, see here for an overview: segger.com/products/debug-prob…nk/models/model-overview/ Best regards, Nino