SEGGER - Nino Administrator

  • Member since Jan 2nd 2017
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Nino -

    Replied to the thread [SOLVED] Infineon XMC 2Go Debug failed , Using JLink V644b.

    Post
    Hi John, Thank you for providing the connect sequence screenshot. From it we can see that from J-Link perspective everything is working correctly. What seems not to be working is DAVE telling J-Link the correct target device name. For this Infineon DAVE…
  • SEGGER - Nino -

    Replied to the thread openocd via jlnik for cortexM0+..

    Post
    Hello, Thank you for your inquiry. Could you provide a photo of your front and backside of the J-Link you are using? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Flasher ARM stand-alone fail.

    Post
    Hello, Thank you for your inquiry. We received your inquiry via our Supportsystem as well. To make sure no information is lost between different channels we will answer you in our Supportsystem. This thread will be closed now. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Infineon XMC 2Go Debug failed , Using JLink V644b.

    Post
    Hello, Thank you for your inquiry. From J-Link perspective the connect seems to have worked. For reference could you provide a screenshot of a J-Link Commander connect sequence? wiki.segger.com/J-Link_cannot_…ty_using_J-Link_Commander From the error…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] JLink SDK User Manual.

    Post
    Hello, Thank you for your inquiry. The J-Link SDK manual is a separate product that needs to be purchased: segger.com/products/debug-prob…nk/technology/j-link-sdk/ As you seem to be coming from a silicon vendor you most likely already have a license.…
  • SEGGER - Nino -

    Replied to the thread Program multiple TM4C boards.

    Post
    Hello, Thank you for your inquiry. Could you tell us your J-Link S/N for reference? Generally the proposed approach can be achieved with the J-Link commander and a J-Link Command File. See J-Link user guide UM08001 in section Using J-Link Command…
  • Hello, Thank you for your inquiry. This is possible however most solutions leave the scope of the capabilities and licensing terms of a J-Link Edu Mini. For Flashing our professional production tool J-Flash can be used. However the J-Link EDU Mini does…
  • SEGGER - Nino -

    Replied to the thread LAUNCHXL CC26X2R1 + Code Composer + JLINK EDU MINI.

    Post
    Hello, Thank you for your inquiry. To be able to connect signals GND, 5V and 3V3 must be jumpered. See here for more details: wiki.segger.com/LAUNCHXL_CC2650 Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread STM32L072 reset when attaching to running program.

    Post
    Hello Paolo, Thank you for your inquiry. The reported issue was reproducible. We are currently working on a fixed J-Link software version. Until then you can use the following workaround: - Create a JLinkScript with function ConfigTargetSettings() -…
  • SEGGER - Nino -

    Replied to the thread RTT slow not usable anymore.

    Post
    Hi, little update in this regard. In the latest J-Link software version V6.44c the RTT Viewer should be back to old speeds and according to our measurements even faster. Could you give it a try and report back your findings? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread can't connect to Syntacore SCR1.

    Post
    Hello, Thank you for your inquiry. Generally all cores that follow standard RISC-V RV32 implementation are supported by J-Link. Quote from dsula: “I've taken up this issue with Syntacore and according to them J-Link is NOT compatible with SCR1 (as…
  • SEGGER - Nino -

    Replied to the thread Telink single-wire support?.

    Post
    Hello, Thank you for your inquiry. From the google links I could not find what core type the Telink chips are. Generally they are currently not supported. If they are Arm cores then you could add support yourself with our Open Flashloader interface. If…
  • SEGGER - Nino -

    Replied to the thread Ozone Breakpoints not setting correctly.

    Post
    Hello, Thank you for your inquiry. We are not exactly sure what you mean from the example you provided. Could you provide a bigger snipped where one can see where the BP is actually set? What behaviour would you expect? What steps do you take when…
  • SEGGER - Nino -

    Replied to the thread j-link not connect to Renesas RX210.

    Post
    Hello, Thank you for your inquiry. Please be aware that this forum is a community forum so there is no guarantee to receive a response here. We tried to reproduce the reported behaviour but everything was working as expected in our example setup. See…
  • Hi Hans, We received this inquiry via Supportsystem as well. To keep all information in one place this thread will be closed now. For everyone else, the minimum recommended RAM size is 5-6 kB. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] QSPI Flash on custom IMXRT1021 board.

    Post
    Hello Dave, Thank you for your inquiry. Please be aware that this is no official support forum so there is no guarantee to receive a response here. If you are entitled to support see my signature for more information. Quote from dmarples: “I can't say…
  • SEGGER - Nino -

    Replied to the thread Is it possible to use J-Link EDU to debug Nuvoton's N76E003 over SWD?.

    Post
    Hello, Thank you for your inquiry. What is the actual name of the target device you are looking to debug? Is it on our public supported devices list? segger.com/downloads/supported-devices.php If not but it is one of our supported core types you can add…
  • Hello, Thank you for your inquiry. The folder you are trying to write to is write protected by admin rights. Simply select another saving location for your project file and you should not see this error message anymore. Alternatively operate J-Flash…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] JFlash resets QSPI bit in IS25LP128 flash chip.

    Post
    Hello Hans, We received your inquiry via Supportsystem as well where the topic has been solved. A fixed version will be available with our next J-Link software beta. This thread will be closed now to avoid double information. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Ozone loads elf file very slowly.

    Post
    Hello Hans, Thank you for your inquiry. We received your inquiry via our Supportsystem as well. To avoid double information this thread will be closed now. Just a quick info to other readers. We were able to improve the load time in this case to around…