SEGGER - Nino Administrator

  • Member since Jan 2nd 2017
Last Activity
, Viewing forum index

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Nino -

    Replied to the thread the principle to program Norflash with flash loader.

    Post
    Hello, Quote from Allen: “I can create a Template_CortexM.elf with SEGGer Embedded Studio, if is the .elf the "RAMCode"? ” Yes the resulting application is the RAMCode. Regarding the demo project for the STM32F469_Discovery board, please note…
  • SEGGER - Nino -

    Replied to the thread Autocomplete file including.

    Post
    Hi, OK that looks weird. It seems like it depends on the system fond used. Which host OS are you running on? I do not see this behaviour on Win10. Best regards, Nino
  • Hello, Thank you for your inquiry. Currently JFlashSPI will always first try to detect the Flash ID. This is to make sure that a reliable connection to the chip is established so no damage can be done. So unfortunately you would have to use your…
  • SEGGER - Nino -

    Replied to the thread Ozone STM32MP1 Coprocessor debugging.

    Post
    Hello Karsten, Thank you for your inquiry. Are you using custom hardware or an eval board? You can find an example project for the STM32MP15X-EVAL on our Wiki: wiki.segger.com/STM32MP15x#Tracing_on_STM32MP15x Could you give the TMC/ETB trace sample a…
  • SEGGER - Nino -

    Replied to the thread the principle to program Norflash with flash loader.

    Post
    Hello, Thank you for your inquiry. J-Link supports two programming modes. Direct and indirect. wiki.segger.com/Programming_External_SPI_Flashes If you want to do direct programming, all you have to do is to wire the SPI Flash to the J-Link debug…
  • SEGGER - Nino -

    Replied to the thread Ozone stuck on "resetting device".

    Post
    Hello, Quote from hs2: “Yes, I'm using the latest non-beta JLink package and also ensure Ozone is not running when installing JLink. ” Ok thank you for verifying. Quote from hs2: “No, as mentioned since it happens sporadically (and luckily not…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] JLink - Connection to LPC55S69 on a Factory Fresh IC.

    Post
    Hello, Thank you for your inquiry. We received your request via our support system in parallel. To make sure no information gets lost between channels this thread will be closed now and the correspondence will continue via e-mail. Best regards, Nino
  • Hello Alessio, Quote from ballotz: “We noticed that RT106x processors are not listed anymore in JLinkDevices.xml (JLink in Ozone 3.20b). ” Yes this is intended behaviour as the QSPI flash loader is now compiled into the J-Link dll. Quote from…
  • SEGGER - Nino -

    Replied to the thread Ozone v3.20b not stopping at main().

    Post
    Hello, Thank you for your inquiry. Sounds like Ozone sets the initial breakpoint on the first mention of main() in the elf file. We would like to look into this and improve Ozone if possible. Could you provide the elf file for reference? As a…
  • SEGGER - Nino -

    Replied to the thread RTT with Keil Compiler 6.

    Post
    Hello, Thank you for your inquiry. Try using __ARMCC_VERSION instead. We will update the RTT sources accordingly with our next software package release. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Ozone: Debug at power-on conditions.

    Post
    Hi, Great to hear that you are up and running. We will consider this thread as closed now. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Ozone: Watched Data variable remembers Refresh over deletion.

    Post
    Hi, that is also unwanted behaviour and will be improved in future versions. Best regards, Nino
  • Hello, Thank you for your inquiry. Such an issue is not known to us. It appears that the clock initialization of your target application is not correct. For reference could you give the attached example project a try? You can rebuild and flash it using…
  • SEGGER - Nino -

    Replied to the thread Autocomplete file including.

    Post
    Hello Maxim, Thank you for your inquiry. The reported behaviour is reproducible and no intended. This will be fixed. Best regards Nino
  • SEGGER - Nino -

    Replied to the thread C++ Standard Library ?.

    Post
    Hello Thomas, Thank you for your inquiry. Embedded Studios C++ library is based on the STLPort and can be installed via the Package Manager. However due to low demand it is based on the C++98 standard with a couple user requested extensions of more…
  • SEGGER - Nino -

    Replied to the thread Auto Completion Very Slow.

    Post
    Hello Fränz, Thank you for your inquiry. For autocomplete to work quickly the indexer must index the project first. Could you check if the indexing process is completed? You can see the progress e.g. in the Source Navigator window. After the indexing…
  • SEGGER - Nino -

    Replied to the thread About the on-board debug solution on Cypress(Spansion) S6E2CC.

    Post
    Hello, Thank you for your inquiry. It appears the guide is a bit outdated. I assume you are stuck at the part which says to install J-Link drivers with COM support. Just download and install the latest J-Link software and you should be good to go:
  • SEGGER - Nino -

    Replied to the thread Missing RAM functions from Execution Profile.

    Post
    Hi Alessio, Ok I was able to Flash the application now. However it gets stuck in the ROM bootloader at 0x00200000 for me. I have the same jumper settings like on your board. Anything else that might need to be considered? If you do a erase of the…
  • SEGGER - Nino -

    Replied to the thread Ozone stuck on "resetting device".

    Post
    Hello, Quote from Zeke: “Here are some logs. These are from after I closed Ozone via task manager. ” Thank you for providing the logs. The J-Link log does not seem to be saved correctly. Is Ozone the only tool in this instance that is connected to…
  • SEGGER - Nino -

    Replied to the thread Ozone stuck on "resetting device".

    Post
    Hi, Thank you for providing the information. Could you send us the J-Link log and Ozone log file for reference? wiki.segger.com/Enable_J-Link_log_file and for Ozone log start Ozone via commandline with parameter -logfile <filepath> Best regards, Nino…