SEGGER - Nino Administrator

  • Member since Jan 2nd 2017
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Nino -

    Replied to the thread What algorithm is used for the Source Viewers assembly display?.

    Post
    Hello, FYI. We improved Ozone so he display of size optimized code in the inline disassembly is accurate now. This will be available with the next Ozone update. You can subscribe to our notification mail to stay up to date:
  • SEGGER - Nino -

    Replied to the thread automatic indentation is not working with tabs.

    Post
    Hello, Thank you for providing the option information. With it the behaviour is reproducible. We are currently investigating. I will inform you once we have new information about this topic. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Go To Definition NOT work.

    Post
    Hello, It sounds this issue may be related to the indexer not having finished its job. Do you have a rather large project? In the Source Navigator window, do you see the indexer still running? If yes wait for the indexer to finish its task. After that…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Timeline not showing SysTick or Scheduler events.

    Post
    Hello Pieter, Thank you for your inquiry. Quote from piconomix: “Feedback for the Segger R&D team: I noticed this comment in the documentation, but the implication should really be explained better: In case timestamp is not retrieved from cycle…
  • SEGGER - Nino -

    Replied to the thread automatic indentation is not working with tabs.

    Post
    Hello, Thank you for your inquiry. Such an issue is not known to us. Could you provide your exact settings that you have changed that lead to said behaviour? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread What algorithm is used for the Source Viewers assembly display?.

    Post
    Hello, Thank you for your inquiry. Generally we do not recommend to have optimizations active when trying to debug as debug information may be missing which is crucial for many of the Ozone features. On first glance it also appears that gdb is not…
  • SEGGER - Nino -

    Replied to the thread Ozone stuck on "resetting device".

    Post
    Hello, Yes, the issue is not fixed yet and it is still being worked on. As it is at a timing related issue the setup specifics are crucial and it is why it is extremely difficult to reproduce for our developer team as we do not have the exact same host…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Segger Ultra broken IC recognise.

    Post
    Hello, Thank you for your inquiry. We are not allowed to share this information via our public forum. But if you like we can provide you this information via our support system. Simply open a ticket as described below referencing this forum post. I…
  • SEGGER - Nino -

    Replied to the thread Suggestion to make Linux executables lowercase.

    Post
    Hi, Thank you for your suggestion. We will discuss this by the end of next week and come back to you once we have news. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Reflashing ST-Link V2 to J-Link on my STM32F4Discovery does not work.

    Post
    Hello Thomas, We received now a new MB997D board (Rev. C boards are no longer sold by ST) where we converted the ST-Link as described here: segger.com/products/debug-prob…j-links/st-link-on-board/ And everything is working as expected. Did you make…
  • SEGGER - Nino -

    Replied to the thread ARM Mbed OS export and Segger.

    Post
    Hello, Thank you for your contribution to the community. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Data sampling for array data.

    Post
    Hi, Thank you for clarifying. This is currently not possible. But we will add it to our wishlist for future features for Ozone. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] PC-lint - error 305: unable to open module.

    Post
    Hi, Ah I see, good to hear that you are up and running again. We will consider this thread as solved now. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Hot key and keyboard layout.

    Post
    Hi, Thank you for providing additional information. We will see what we can do to improve the experience with such keyboard layouts as well. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Correct typing of Thumb functions for "SEGGER_THUMB_Startup.s ".

    Post
    Hello, No worries, and yes, the nRF package does not come with the correct startup yet. But an update is planned shortly. All other packages that are not transformed yet will also be updated by us. But if you generate a generic project for your target…
  • SEGGER - Nino -

    Replied to the thread JLink TI 14-pin to ARM 20-pin adapter.

    Post
    Hello, A list of our distributors can be found here: segger.com/purchase/distributors/ Unfortunately we do not get the stocking information from them so you would have to contact the distributors directly. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Linux: a lot of issues in dark mode.

    Post
    Hello, Thank you for your inquiry. Dark mode is not supported officially and as you found out correctly, Ozone simply uses the current OS theme. A proper darkmode is on our ToDo but no fixed timeschedule yet. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Linux: V3.20e, text in status bar flickering.

    Post
    Hello, Thank you for your inquiry. Such an issue is not known to us. Could you provide a video or gif showing the behaviour? What Linux version are you using exactly? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Linux: wrong version shown?.

    Post
    Hi, Thank you for your inquiry. I just gave it a quick try on a Ubuntu18 VM and the versions were showing up correctly for both the deb and tgz. Most likely this is somehow related to your specific Linux config. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Data sampling for array data.

    Post
    Hello Max, Thank you for your inquiry. You can display the data in a table in the Data Sampling window in the Samples tab. If you right click the content you can also export it. Best regards, Nino