SEGGER - Nino Administrator

  • Member since Jan 2nd 2017
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Nino -

    Replied to the thread RTT Control Block not Found (only on auto detect) on STM32H7 Nucleo.

    Post
    Hello Daimonion, Thank you for your inquiry. RTT control block autodetection for the STM32H7 series will only work for RAM area 0x20040000 and up due to some device specific defaults. So you need to add other RAM areas manually. This can be done in…
  • SEGGER - Nino -

    Replied to the thread SystemView reset board on each starting loading..

    Post
    Hello, Thank you for your inquiry. What target device are you debugging exactly? How is your setup? Do you run SystemView standalone or in parallel to a debug session in an IDE? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread SystemView Kernelpatch for FreeRTOS 10.2.0.

    Post
    Hello Daimonion, Thank you for sharing. However the kernel patch for FreeRTOS V10 should be available in the SystemView source shipping for a while now: segger.com/downloads/jlink/systemview_target_src Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread ES Global macros.

    Post
    -- Moved to new thread as it was unrelated to other inquiry-- Hello, Thank you for your inquiry. Try forward slashes when setting paths, that should make it work. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Matching braces.

    Post
    Hello Vlad, The settings look correct. We will check if the issue can be reproduced on our test PCs. Do you see the issue with any file and project or just with a specific one? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread segger linker.

    Post
    Hello Radomir, Thank you for your inquiry. Such an issue is not known to us. Could you provide an example project for reproduction purposes? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Dependencies not honored.

    Post
    Hello, Thank you for your inquiry. Such an issue is not known to us. Is the header file name always the same? Are you using dynamic virtual folders or static ones? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Ozone Power Graph - start/stop recording when debugging.

    Post
    Hello Duane, Thank you for your inquiry. Such an issue is not known to us. We tried to reproduce the reported issue with the Cortex-M Trace Reference Board and the tutorial project: segger.com/products/debug-probes/j-trace/ But everything was working as…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] FreeRTOS aware in Segger Embedded Studio.

    Post
    Hello Thomas, Thank you for your inquiry. How to enable thread awareness in ES is explained here: wiki.segger.com/SEGGER_Embedde…ble_RTOS_thread_awareness Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Specify default build configuration?.

    Post
    Hello, Thank you for your inquiry. You have two options here. Either via the emProject file where your build config is memorized. There the build configs are simply sorted alphabetically so if you open en emProject file the first time it will autoselect…
  • SEGGER - Nino -

    Replied to the thread Debug Does Not Stop at initial break point.

    Post
    Hello, Thank you for your inquiry. So you want to start debugging from the reset hanlder and not from main correct? In that case starte the debug session with F11 instead of F5. This will "step into" the application and you will halt at the absolute…
  • SEGGER - Nino -

    Replied to the thread Problems configuring project for SystemView using SES.

    Post
    Hello, Quote from ClarkS: “One MAJOR difference between Segger and all the other embedded system IDE and tool manufacturers is that Segger actually offers support. The other's have support sites but questions there go unanswered. As far as I can tell,…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] SES 4.16 not showing RTT output.

    Post
    Hello, Thank you for your inquiry. Such an issue is not known to us. We tried to reproduce the issue but RTT data was showing up just fine in Embedded Studio 4.16. Attached you can find the example project used. Could you test your setup with that…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] In need of older version of J-Link ARM.

    Post
    Hello Tomas, Thank you for your inquiry. You can find J-Link software V5 and up on our website. Older versions are not listed. To acquire them please open a support request through our official support channel. How is described in my signature. Best…
  • SEGGER - Nino -

    Replied to the thread Hidden warnings, modifying the include path, path prefix.

    Post
    Hello, Thank you for your feedback. 1: Simply press F4. This should take you to the first warning. 2: Try project options->Preprocessor->User include directories 3: You can set as many macros as you want under Tools->Options->Building->Build->Global…
  • SEGGER - Nino -

    Replied to the thread Matching braces.

    Post
    Hello, Thank you for your inquiry. You can find the matching braces settings under Tools->Options->Text Editor->Visual Appearance Then the settings for "Mate Match off Screen" and "Mate matching mode". Both should be enabled so that it works. What are…
  • SEGGER - Nino -

    Replied to the thread Could not perform target reset failed to connect.

    Post
    Hello, Thank you for your inquiry. The BCM89103 seems to be a MIPS32 core and not Cortex-M7. Are you certain you mean the BCM89103? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Program XMC4800 with JLink ARM with a script.

    Post
    Hello, J-Flash is currently not available in Arm tools, but you can achieve something similar to this with J-Link Commander. With a commandfile you can execute J-Link commands in batch like fashion. More information can be found in the J-Link user…
  • SEGGER - Nino -

    Replied to the thread Bug: breakpoint fails in ISR with FreeRTOS debug.

    Post
    Hello Dave, Thank you for your inquiry. Could you give the latest J-Link software version a try? Does that change the behaviour? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Problems configuring project for SystemView using SES.

    Post
    Hello, Thank you for your inquiry. The warnings come from the .patch file which is in your project. We recommend removing that file after applying that patch to FreeRTOS. Otherwise you will get such redefinition errors. Or if you want to keep it in the