SEGGER - Nino Administrator

  • Member since Jan 2nd 2017
Last Activity
, Reading thread Jtrace + SWO Pin + [Ozone debugger vs STM32CubeIDE] clock sliding - ITM trace

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Nino -

    Replied to the thread Autocomplete file including.

    Post
    Hello Maxim, Thank you for your inquiry. The reported behaviour is reproducible and no intended. This will be fixed. Best regards Nino
  • SEGGER - Nino -

    Replied to the thread C++ Standard Library ?.

    Post
    Hello Thomas, Thank you for your inquiry. Embedded Studios C++ library is based on the STLPort and can be installed via the Package Manager. However due to low demand it is based on the C++98 standard with a couple user requested extensions of more…
  • SEGGER - Nino -

    Replied to the thread Auto Completion Very Slow.

    Post
    Hello Fränz, Thank you for your inquiry. For autocomplete to work quickly the indexer must index the project first. Could you check if the indexing process is completed? You can see the progress e.g. in the Source Navigator window. After the indexing…
  • SEGGER - Nino -

    Replied to the thread About the on-board debug solution on Cypress(Spansion) S6E2CC.

    Post
    Hello, Thank you for your inquiry. It appears the guide is a bit outdated. I assume you are stuck at the part which says to install J-Link drivers with COM support. Just download and install the latest J-Link software and you should be good to go:
  • SEGGER - Nino -

    Replied to the thread Missing RAM functions from Execution Profile.

    Post
    Hi Alessio, Ok I was able to Flash the application now. However it gets stuck in the ROM bootloader at 0x00200000 for me. I have the same jumper settings like on your board. Anything else that might need to be considered? If you do a erase of the…
  • SEGGER - Nino -

    Replied to the thread Ozone stuck on "resetting device".

    Post
    Hello, Quote from Zeke: “Here are some logs. These are from after I closed Ozone via task manager. ” Thank you for providing the logs. The J-Link log does not seem to be saved correctly. Is Ozone the only tool in this instance that is connected to…
  • SEGGER - Nino -

    Replied to the thread Ozone stuck on "resetting device".

    Post
    Hi, Thank you for providing the information. Could you send us the J-Link log and Ozone log file for reference? wiki.segger.com/Enable_J-Link_log_file and for Ozone log start Ozone via commandline with parameter -logfile <filepath> Best regards, Nino…
  • Hi, Thank you for your inquiry. The behaviour is intended as SystemView V2 was essentially a complete different software than V3. So it is possible that the V2 package will not be detected as a predecessor of V3. But from V3 on the packages should be…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] MAC7111 locked after Chip Erase.

    Post
    Hello, Thank you for your inquiry. Unlock Kinetis may only work for NXP Kinetis target devices and not the MAC7xxx series. On many legacy ARM7/9 target devices debug interface speeds are not consistent. So it is possible that this target device has such…
  • SEGGER - Nino -

    Replied to the thread Ozone: Debug at power-on conditions.

    Post
    Hi, The Arm debug interface is unfortunately not designed to catch such power on issues directly. So proper debugging as you know it with J-Link usually will not work. The only viable way is to write debug messages or variable values to some buffer on…
  • SEGGER - Nino -

    Replied to the thread Ozone: Watched Data variable remembers Refresh over deletion.

    Post
    Hi, Thank you for your inquiry. We have added this as an improvement to our ToDo. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Ozone stuck on "resetting device".

    Post
    Hello, Thank you for your inquiry. We are aware of this issue, however so far no one could provide us with a working reproduction scenario. Could you provide us with reproduction steps that work reliably? What is your debug setup? Which J-Link? What is…
  • SEGGER - Nino -

    Replied to the thread cmd line without message boxes possible ?.

    Post
    Hello, Thank you for your inquiry. Which pop-up do you refer to exactly? Could you provide a screenshot of it? What is the J-Link serial number you are currently using? Quote from M0NKA: “Yes, i can use the STLink perfectly, but wanted to see if…
  • SEGGER - Nino -

    Replied to the thread Disable EZ_Port although hard set through pin.

    Post
    Hi, Thank you for your inquiry. To our knowledge the only way to disable the EZPort is by pulling the EZP_CS pin high. For information if there is a non-official/undocumented way we recommend contacting the silicon vendor. The inconsistencies in the…
  • SEGGER - Nino -

    Replied to the thread Systemview license requirement.

    Post
    Hello, Thank you for your inquiry. SystemView PRO may only be used commercially with a PRO license that has to be bought. There are currently also no deals in place with silicon vendors like it e.g. is for Embedded Studio. In the past there were two…
  • SEGGER - Nino -

    Replied to the thread Patch for FreeRtos version 10.3.1.

    Post
    Hello, Thank you for your inquiry. The patch files provided with SystemView are only examples and provide a reference for some versions so customers can easily create their own patches. So it is possible that not all of the available FeeRTOS releases…
  • SEGGER - Nino -

    Replied to the thread Embedded Studio - problem whith import IAR project.

    Post
    Hi, Thank you for your inquiry. A generic guide on how to port project from IAR to ES can be found here: wiki.segger.com/Port_Projects_…kbench_to_Embedded_Studio Not all information can be translated from IAR during the import process e.g. some…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Version Marco Expansion Building from GUI and embuild.

    Post
    Hello Darren, Good to hear that you are up and running again. You can find documentation about this here: studio.segger.com/ide_project_macros.htm We will consider this case as closed now. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Memory usage windows and data (load) sections.

    Post
    Hello, Thank you for your inquiry. Please note that this forum is no support forum. As you are working for one of our silicon vendor partners we recommend to contact us via our support system. For more information see my signature. When opening the…
  • SEGGER - Nino -

    Replied to the thread Issue of changing the value of variables/flags automatically.

    Post
    Hello, Thank you for your inquiry. The reported behaviour does not seem to be related to issues in SEGGER software. So please understand that we can't put much time into this request as it is user responsibility to debug and write user code. But as a…