SEGGER - Nino Administrator

  • Member since Jan 2nd 2017
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • SEGGER - Nino -

    Replied to the thread J-Trace and IAR.

    Post
    Hello Gawie, Yes IAR will utilize the 64 MB on board buffer so depending of the target speed and created trace data this can be enough to reconstruct the last couple of seconds. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread [SOLVED] SFR display not working for register arrays of nRF52840.

    Post
    Hello Dirk, Great to hear that you are up and running again. As the initial inquiry has been solved this thread will be closed now. Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Sow to determine MAC address used for SES License.

    Post
    Hi Russ, Oh OK, I assumed you already gave our sales team the MAC addresses, sorry for the confusion. When choosing the "right" MAC address we recommend choosing a physical one which is build into your PC, like the Ethernet controller or build in…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Ozone.

    Post
    Hello, Thank you for your inquiry. We received your inquiry via e-mail in parallel. For future inquiries please try to use only one contacting channel, otherwise it can happen that information gets lost between channels which can lead to unnecessarily…
  • SEGGER - Nino -

    Replied to the thread J-Trace and IAR.

    Post
    Hello, Thank you for your inquiry. IAR unfortunately does not support any streaming trace features. For the best trace experience we recommend using Ozone the J-Link debugger. It can be used for free with a J-Trace PRO and works with IAR output formats.…
  • SEGGER - Nino -

    Replied to the thread Issue related to debugging GHS compiled elf on S32K.

    Post
    Hello, Thank you for your inquiry. Native J-Link support in GHS debugger has been removed by Greenhills a while ago. So at this current point in time we can't give any assistance with Greenhills setups as they are no longer supported. For any setup…
  • SEGGER - Nino -

    Replied to the thread JLink OB on Nordic nRF52 Dongle on Mac.

    Post
    Hello, Thank you for your inquiry. Quote from Mron: “I've seen this as an old issue that was fixed about 4 years ago with nRF51 Dongles. Any help is appreciated. ” If that is the case then it should work with nRF52 as all eval boards known to us…
  • SEGGER - Nino -

    Replied to the thread J-Link support for ZGM130S037HGN.

    Post
    Hello, Thank you for your inquiry. We can't find any information about the ZGM130S037HGN. Could you provide a reference link? What Coretype is it? Currently supported devices can be found here: segger.com/products/debug-prob…pported-cpus-and-devices/
  • SEGGER - Nino -

    Replied to the thread Ozone issue with ADS generated axf image.

    Post
    Hello, Thank you for your inquiry. This sounds like an incompatibility of the elf file with current standards. Could you provide us with the elf file so we could check if there is a generic issue with Ozone interpreter? Best regards, Nino
  • SEGGER - Nino -

    Replied to the thread Sow to determine MAC address used for SES License.

    Post
    Hello Russ, Thank you for your inquiry. If I see correctly you have purchased Mac locked ES licenses. In that case at some point you provided our sales team with MAC addresses of your PCs to lock the licenses to. Additionally you should have received a…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] SFR display not working for register arrays of nRF52840.

    Post
    Hi Dirk, Quote from dzabel: “(the "v3" seems strange to me, I have installed the SES v4.10a, but there is no "v4" folder). ” This is due to backwards compatibility as between v3 and v4 there were no changes for package handling so the name was kept…
  • SEGGER - Nino -

    Replied to the thread Embedded Studio debug terminal displays random junk periodically.

    Post
    Hello, Thank you for your inquiry. Such an issue is not known to us. Embedded Studio will only display what data it finds in the RTT buffer. So it is save to assume that for some reason "garbage" data is written into RTT Buffer. RTT is provided in…
  • SEGGER - Nino -

    Replied to the thread Debugger code upload clear flash ?.

    Post
    Hello, Thank you for your inquiry. Such an issue is not known to us. J-Link will usually only delete used sectors and leave everything else untouched. Did you verify that the application that has been downloaded at all? What target devices are you…
  • SEGGER - Nino -

    Replied to the thread STM32 Example Project and Timer Problem.

    Post
    Hello Joe, Thank you for your inquiry. When importing more complex projects from IAR or Keil to Embedded Studio there are certain steps that need to be considered regarding compatibility. An example guide for a proper import can be found here:
  • SEGGER - Nino -

    Replied to the thread [SOLVED] Can't configure STLPort.

    Post
    Hello, Thank you for the update. Good to hear that you are up and running again. This thread will be closed now. Best regards, Nino
  • Hello, Thank you for the flowers, we try our best to answer between software projects ;) Quote from Anders: “Figuring it was worth a try and disabling my AMD driver, my build time went from 80 seconds to 19 seconds. I have absolutely no idea why, and…
  • SEGGER - Nino -

    Replied to the thread [SOLVED] MEM_MAP.c error with STM32G071.

    Post
    Hello, Quote from pasnew: “the Flash content of 0x08000000 (or system memory, depend on boot0 pin) is mapped at address 0x0 at boot time (refer to RM0444, section 2.5 Boot configuration, page 58). ” Yes we know, and this is exactly why IARs…
  • SEGGER - Nino -

    Replied to the thread JLink RT1052 flash problem.

    Post
    Hello, Thank you for providing the logs. The Flash loader used here has been developed to work with a IMXRT1050-EVKB board. To work on the embedded artists board all QSPI connections must be identical. If not the Flash loader must be…
  • SEGGER - Nino -

    Replied to the thread Unable to continue past bkpt instruction.

    Post
    Hello, Thank you for your inquiry. Please be aware that the referenced post is over 4 years old so it is highly unlikely that the issues are related. The J-Link software version you are using is rather old, could you try the latest one and see if the…
  • SEGGER - Nino -

    Replied to the thread RTT slow not usable anymore.

    Post
    Hello, Thank you for your inquiry. Such an issue is not known to us with the latest version. Which J-Link software version are you currently using? Does the behaviour improve when using the latest one? Quote from timurlocumi: “We have been using RTT…