v01d Student

  • Member since Feb 29th 2016
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • v01d -

    Replied to the thread How to set JLink to never power the board.

    Post
    Hey Fabian, will do asap with photo & details, but i'm on something else this week and/or few days.
  • v01d -

    Replied to the thread [SOLVED] r (reset) triggers flash write trace ....

    Post
    Thanks Alex, On breakpoints Quote from SEGGER - Alex: “ Again: It has *nothing*(!!!!) to do with flash breakpoints. ” OK, I started that from : Quote from SEGGER - Fabian: “ One reason could be, if you have any flash break points…
  • v01d -

    Replied to the thread How to set JLink to never power the board.

    Post
    Fabian, Quote from SEGGER - Fabian: “In the beginning you are writing about an issue with the J-Link EDU ” Yea sorry for confusion : it is the J-Link EDU MINI that I _think_ /believe I have issue with, not J-Link EDU . ( The latter I used to re-test…
  • v01d -

    Replied to the thread How to debug code in external RAM?.

    Post
    Quote from eTLA: “..... initializes QSPI and SDRAM .... So I'm wondering, how to set up Seggers tools (preferably Ozone) to initialize the external SDRAM, write the program to the SDRAM and execute it with full debugging access? .... ” In…
  • v01d -

    Replied to the thread [SOLVED] r (reset) triggers flash write trace ....

    Post
    Hi Fabian, Thanks for your time to describe how the internals of the JLink soft/dll work. Just want to clarify your last post. Quote from SEGGER - Fabian: “ Since loadfile is always flushed directly, this leads to the described behavior. ” Way I…
  • v01d -

    Replied to the thread How to set JLink to never power the board.

    Post
    Quote from SEGGER - Fabian: “.... From your description it is highly likely that your EDU was damaged from the USB side. This could have multiple reasons (e.g. resistors burned, faulty USB power supply). ..... ” Hello Fabian, Issue does not appear…
  • v01d -

    Replied to the thread [ABANDONED] Thread aware debugging broken on FreeRTOS 10.2.1.

    Post
    Quote from jeremy.billheimer: “ Relevant error is: Received symbol: pxCurrentTCB (0x00000000) ERROR: Mandatory symbol pxCurrentTCB not found. pxCurrentTCB is defined and I can set a watch on it. ” You prob need to patch a little your FreeRTOS. …
  • Hi, So you cannot / do not want to just pass this on command line to the JLinkGDBServer ? That's how those specific options are usually set - on startup of that prog, from command line.
  • v01d -

    Replied to the thread [SOLVED] r (reset) triggers flash write trace ....

    Post
    Quote from SEGGER - Fabian: “One reason could be, if you have any flash break points enabled. ” Just "enabled" (e.g. flash breakpoints = 1) or if set any? Does it mean that, on any reset, even if I don't change the program, it re-flashes? What…
  • Quote from SEGGER - Fabian: “.. We always get stuck in the boot loader at address 0x000029B8..... Best regards, Fabian Federschmidt ” Hi Fabian. I now got your case, and I have the steps for you to replicate the issue. Please start by examining…
  • v01d -

    Posted the thread A HOWTO: loading & staring app binary for TI CC3220SF.

    Thread
    I saw that Segger support didn't know how to to load my provided binary/app built for TI CC3220SF MCU, so I thought I 'll write the steps for how to do it. Assume you have a CC3220SF with a blank-app image Development image (refer to the chip user…
  • Quote from SEGGER - Fabian: “ We always get stuck in the boot loader at address 0x000029B8. ” Can I ask you, how did you manage to get the bootloader/ROM code stuck at that address? I tried many things, changing jumper settings, etc.. I seems…