v01d Student

  • Member since Feb 29th 2016
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Quote from SEGGER - Fabian: “.. We always get stuck in the boot loader at address 0x000029B8..... Best regards, Fabian Federschmidt ” Hi Fabian. I now got your case, and I have the steps for you to replicate the issue. Please start by examining…
  • v01d -

    Posted the thread A HOWTO: loading & staring app binary for TI CC3220SF.

    Thread
    I saw that Segger support didn't know how to to load my provided binary/app built for TI CC3220SF MCU, so I thought I 'll write the steps for how to do it. Assume you have a CC3220SF with a blank-app image Development image (refer to the chip user…
  • Quote from SEGGER - Fabian: “ We always get stuck in the boot loader at address 0x000029B8. ” Can I ask you, how did you manage to get the bootloader/ROM code stuck at that address? I tried many things, changing jumper settings, etc.. I seems…
  • Note: TI forum support confirmed the reported issue as per thread: thus they 've confirmed the issue independently. But I don't think they can do anything about it : as this is Segger specific.
  • Hello Fabian, Quote from SEGGER - Fabian: “We were using the TI CC3220 LaunchPad (wiki.segger.com/CC3220_LaunchPad). ” No, technically it is CC3220SF, not CC3220. I believe difference is external serial flash - please double check. Quote from…
  • v01d -

    Replied to the thread Problem with J-Link SWD Isolator.

    Post
    Quote from awneil: “Quote from simone: “does not connect ” note that Segger have a Wiki page on resolving connection issues: wiki.segger.com/J-Link_cannot_connect_to_the_CPU ” He did write that, connects initially & programs. Could you re-check his…
  • v01d -

    Posted the thread r (reset) triggers flash write trace ....

    Thread
    I see that doing a 'r' / reset command in J-Link, causes a flash write traces, and , I do not understand why. Most importantly I guess to know if it's actually erasing/writing anything just because I wanted reset .. and why. I load/flash image just…
  • v01d -

    Replied to the thread Problem with J-Link SWD Isolator.

    Post
    Quote from simone: “I have a problem with J-Link SWD isolator too, when using production programming but for STM32 devices. The first time I program a board it is programmed succesfully, then the second fails. So what I see is alternating exactly one…
  • v01d -

    Replied to the thread Problem with J-Link SWD Isolator.

    Post
    Quote from SEGGER - Alex: “... Not sure what board you use but is the board designed to also allow drawing current on the VTref pin? (pin 1) This is needed as the SWD isolator uses VTref to adjust its target buffers for the correct HIGH levels but also…
  • v01d -

    Posted the thread Problem with J-Link SWD Isolator.

    Thread
    Problem is I cannot connect to target when J-Link SWD Isolator is in between. I wanted to use the isolator to connect to the target TI CC32220SF board, in SWD mode. The SWD mode without isolator works. Why doesn't this work with the SWD isolator ...…
  • v01d -

    Replied to the thread Is J-Link PRO supporting multiple GDB Servers connected via Ethernet (i.MX6Q).

    Post
    Quote from SEGGER - Alex: “.... This will then allow multiple connections via IP (if all come from the same host PC) .... ” Nice to know Alex, thanks for update.
  • v01d -

    Replied to the thread Is it possible to insert comments in a .jlink script?.

    Post
    Quote from rdpoor: “I have a mildly complex JLink.exe script that gets launched from a .bat file via Source Code (1 line)... and I'd like to make it so others (including my future self) can understand what's going on in myscript.jlink. Is there a way…
  • v01d -

    Replied to the thread How to set JLink to never power the board.

    Post
    Hey Fabian, Quote from SEGGER - Fabian: “For sanity reasons could you try the same Setup with your J-Trace Pro? ” If you see above - I did already, see post from Oct 31st 2019 on this thread. I will re-check. I will re-try with my J-Link EDU too, not…
  • v01d -

    Replied to the thread [SOLVED] Relocate symbols in OZONE.

    Post
    Quote from lukma: “Hi, Just to test if I can "break" the execution of the code (in some random place) - see if symbols are correctly loaded (after relocation) and resume. ” Oh ok. When you halt the target CPU at a random place with the monitor…
  • Quote from lukma: “ The original question was about the possibility to emulate/generate with Segger setup the TRST and !RESET signals with micro seconds resolution. ” It is true, apologies :) I still do not understand why you want /need it. For what…
  • Quote from lukma: “Hi, Thank you for your response. My approach (I think that it is what your suggested above): ” Lukma, If you / your Co is willing / in -need, I can deliver a working debug setup on U-boot and Linux kernel, for your SoC/board, if…
  • Hey Lukma, Quote from lukma: “(gdb) target remote localhost:2331 (gdb) hb *0x908000 ........... ” Yes.. Quote from lukma: “However, I would like to know how early I can stop the i.MX6Q when I do generate the reset (with 'mo reset'). This may be…
  • v01d -

    Replied to the thread RTOS plugin when no GDBServer used ( = IDE / tool uses jlink dll ).

    Post
    Hi Nino, Quote: “..... The GDB Server plugin is not compatible to Ozone or ES as the GDB Server has to use another approach due to the limitations of the GDB Protocol. So you can only use the available plugins from us in third party IDEs if the IDE…
  • v01d -

    Replied to the thread [SOLVED] Relocate symbols in OZONE.

    Post
    Quote from lukma: “... I would like to do it without any breakpoints set (HW or SW). Just break the execution of the code (at some random place), load symbols with offset - inspect the code and just resume execution. ” This seems a little…