pasnew Beginner

  • Member since May 13th 2015
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • pasnew -

    Replied to the thread [SOLVED] MEM_MAP.c error with STM32G071.

    Post
    Hi, As you can see the memory viewer of Embedded Studio, it failed to access memory at address 0x0. This is not an intended behavior, as the Flash content of 0x08000000 (or system memory, depend on boot0 pin) is mapped at address 0x0 at boot time (refer…
  • pasnew -

    Replied to the thread [SOLVED] MEM_MAP.c error with STM32G071.

    Post
    I found the corrupt of the NMI interrupt, it's cause by SRAM parity check I enabled previously in another project. Since by default RAM is not erased at startup, parity error could occur. So I reset option bytes. Following are 2 memery map at address 0…
  • pasnew -

    Replied to the thread [SOLVED] MEM_MAP.c error with STM32G071.

    Post
    In the attachment there are: - iar fail.log : J-Link log of the failing session with IAR, we can see the MemMap error message. - ozone.log : Same error when debugging iar output file with OZone. - test.zip : Iar output file. - embedded studio.zip :…
  • pasnew -

    Replied to the thread [SOLVED] MEM_MAP.c error with STM32G071.

    Post
    I've reached IAR support, using their demo project same error occurred. Seems like not an issue of IAR ?
  • pasnew -

    Replied to the thread [SOLVED] MEM_MAP.c error with STM32G071.

    Post
    Thanks for your reply. In fact I link my application to 0x08000000, same error occurred with sample code shipped with STM32Cube. Here is my linker script: Source Code (33 lines)Another bug is as soon as RTT client is opened, MCU goes into NMI interrupt.…
  • pasnew -

    Posted the thread [SOLVED] MEM_MAP.c error with STM32G071.

    Thread
    Hi, This error occurred I click debug, but debug function actually works. Probe: J-Link V10 EDU 6.40b IDE: IAR 8.32 MCU: STM32G071CBT6 forum.segger.com/index.php/Att…f6c932edc87b6f2a368e7eb1e Do you need more error log ?