ali_asadzadeh Community Member

  • Member since Mar 14th 2015
Last Activity

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • ali_asadzadeh -

    Replied to the thread [SOLVED] Can not compile or run embos on stm32f103rbt6.

    Post
    Dear Martin Hi, Thanks for the update, I use keil to make new projects, not stm32cube, maybe the bug comes from there. Please try to make a new project using keil only, there is a checkmark with in the device the triggers stm32cube framework code…
  • ali_asadzadeh -

    Replied to the thread [SOLVED] Can not compile or run embos on stm32f103rbt6.

    Post
    Dear Martin Hi Thanks for the update, Now it compiles, Please add the updates to the new release, also I wanted to test the embos on stm32F0 parts too, they needed stmcube code generation for new project to be setup, But if I add embos to the mix, it…
  • ali_asadzadeh -

    Replied to the thread [SOLVED] Can not compile or run embos on stm32f103rbt6.

    Post
    Also Please note that my keil version is 5.38 and I'm using arm compiler version 6.19 and I have also tried to compile your STM32F103_STM32_SK example, and I would get the compilation error like this Quote from keil: “Build started: Project:…
  • ali_asadzadeh -

    Replied to the thread [SOLVED] Can not compile or run embos on stm32f103rbt6.

    Post
    Dear Martin Hi, Thanks for the update, I have used the default keil startup file Adding the EXPORT Stack_Mem and EXPORT __initial_sp would generate some errors, Now I have uncommented the c code required for embos to it's original state like this C…
  • ali_asadzadeh -

    Posted the thread [SOLVED] Can not compile or run embos on stm32f103rbt6.

    Thread
    Hi I have setup a simple project to test embos with stm32f103rbt device, I just used the default settings, after changing the default complier warnings to MISRA compatible and changed the C standard to C99 and C++ to C++11 most of the errors would go…