Problem while erasing the STM32 chip using Segger J-Link Pro

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Problem while erasing the STM32 chip using Segger J-Link Pro


      I am using STM32f722RE based custom board, while performing the flash erase, getting the following error log in J-Flash V7.52b (*i have also tried latest version of J-Flash but saw same error log).

      Erasing chip ...

      - Connecting ...
      - Connected successfully
      - 10 sectors, 3 ranges, 0x8000000 - 0x807FFFF, 0x1FFF0000 - 0x1FFF001F, 0x90000000 - 0x93FFFFFF
      - Start of preparing flash programming
      - ERROR: Verification of RAMCode failed @ address 0x20000020.
      Write: 0xB404D1FA D5F51E5B
      Read: 0xD404D1FA D5F51E5B
      - ERROR: Failed to prepare for programming.
      Failed to download RAMCode!
      - End of preparing flash programming
      - Start of restoring
      - End of restoring
      - ERROR: Failed to erase chip
      Disconnecting ...
      - Disconnected

      Flashing bin and hex file is also not working.

      i have also verify that is there something wrong with a chip using ST-LINK/V2 and STM32CubeProgrammer, erase and programming the .bin file is working with same chip.

      Anyone has idea why it is not working with Segger J-Link Pro.

      I have attached the j-Flash project file.