[SOLVED] J-Trace Pro not functioning correctly over USB

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Trace Pro not functioning correctly over USB

    When I connect my J-Trace Pro Cortex to my Windows 10 PC, the device enumerates correctly and loads the WinUSB driver for it. It shows up as "J-Trace PRO" under "Universal Serial Bus devices" in device manager. When I open J-Link Commander I get the following messages:

    Connecting to J-Link via USB...Out of sync , resynchronizing... Out of sync , resynchronizing... Out of sync , resynchronizing... FAILED: Cannot connect to J-Link

    I've tried on three different Windows 10 PCs and with two different USB-SS cables, and one regular USB cable. I can connect to it over ethernet, and everything works fine, except for the attached message when I first connect to it in Microchip Studio:

    Device: R7S921040VCBG_SPIBSC_OctaFlash: Flash bank 0x30000000: No loader specified

    I have never used a Renesas RZ/A2M CPU, and there isn't one inside the J-Trace Pro (as far as I can see...) so where is that coming from? I use Microchip/Atmel CPUs almost exclusively, currently using it with ATSAMV71.

    I hope someone can help me fix this, because I really do not want to spend USD$2,400 to replace it after owning it for only 3 years. I'm certain it was working fine the last time I used it in 2023. I've updated the firmware (over ethernet) to Firmware build: May 15 2024 13:31:01 with no improvement.
    • Capture.PNG

      6.1 kB, 497×118, viewed 50 times
  • Can you please PM me the S/N of your J-Trace unit?
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.