[SOLVED] RTT on ARM1176?

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] RTT on ARM1176?

    Can RTT be made to work on an ARM1176 target? Yes, I know it is now ancient silicon. After some tinkering, there seems to be some suggestions that it might be impossible due to no "background memory access"?

    The control block is definitely linked and sitting at 0x00012940, but there's no RTT output on the terminal,

    And the Ozone console surfaces that BMA error:
    1:04:15.579 090 Edit.SysVar (VAR_ALLOW_BMA_EMULATION, 1);
    1:04:17.144 014 System settings were written to the project file.
    1:04:22.302 502 Project.SetRTT (1);
    1:04:22.302 598 RTT has been activated, however the hardware does not support background memory access or BMA emulation is not permitted (see system variable VAR_ALLOW_BMA_EMULATION)
    1:04:22.302 611 RTT active
    1:04:22.339 392 Error (78): Failed to activate RTT .
    1:04:22.339 421 RTT inactive
  • Hi,

    There is no RTT support for ARM11, as ARM11 does not support background memory access.

    The “emulation mode” is also not available for ARM11
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.