SystemView recording does not start (MacOS MIMXRT1176 Arm M7 FreeRTOS)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • SystemView recording does not start (MacOS MIMXRT1176 Arm M7 FreeRTOS)

      Hi all,

      The issue I'm having:
      When starting a recording using the 'Start a recording' button in SystemView, the 'Starting recording' window comes up and I see the info below in the log window.
      Unfortunately, that is all that happens. The progress bar doesn't advance. Eventually the recording window goes away.
      If I run while debugging, it complains 'JLink: Out of sync , resynchronizing...'
      If I run without the debugger, nothing happens. (The app is confirmed to be running by UART output)
      If I click 'Read recorded data', I get 'RTT Control Block not found'.

      13:04:46 - JLink: Device "MIMXRT1176XXXA_M7" selected.
      13:04:46 - JLink: Found SW-DP with ID 0x6BA02477
      13:04:46 - JLink: DPIDR: 0x6BA02477
      13:04:46 - JLink: CoreSight SoC-400 or earlier
      13:04:46 - JLink: Scanning AP map to find all available APs
      13:04:46 - JLink: AP[3]: Stopped AP scan as end of AP map has been reached
      13:04:46 - JLink: AP[0]: AHB-AP (IDR: 0x84770001)
      13:04:46 - JLink: AP[1]: AHB-AP (IDR: 0x24770011)
      13:04:46 - JLink: AP[2]: APB-AP (IDR: 0x54770002)
      13:04:46 - JLink: Iterating through AP map to find AHB-AP to use
      13:04:46 - JLink: AP[0]: Core found
      13:04:46 - JLink: AP[0]: AHB-AP ROM base: 0xE00FD000
      13:04:46 - JLink: CPUID register: 0x411FC272. Implementer code: 0x41 (ARM)
      13:04:46 - JLink: Cache: L1 I/D-cache present
      13:04:46 - JLink: Found Cortex-M7 r1p2, Little endian.
      13:04:46 - JLink: FPUnit: 8 code (BP) slots and 0 literal slots
      13:04:46 - JLink: CoreSight components:
      13:04:46 - JLink: ROMTbl[0] @ E00FD000
      13:04:46 - JLink: [0][0]: E00FE000 CID B105100D PID 000BB4C8 ROM Table
      13:04:46 - JLink: ROMTbl[1] @ E00FE000
      13:04:46 - JLink: [1][0]: E00FF000 CID B105100D PID 000BB4C7 ROM Table
      13:04:46 - JLink: ROMTbl[2] @ E00FF000
      13:04:46 - JLink: [2][0]: E000E000 CID B105E00D PID 000BB00C SCS-M7
      13:04:46 - JLink: [2][1]: E0001000 CID B105E00D PID 000BB002 DWT
      13:04:46 - JLink: [2][2]: E0002000 CID B105E00D PID 000BB00E FPB-M7
      13:04:46 - JLink: [2][3]: E0000000 CID B105E00D PID 000BB001 ITM
      13:04:46 - JLink: [1][1]: E0041000 CID B105900D PID 001BB975 ETM-M7
      13:04:46 - JLink: [1][2]: E0042000 CID B105900D PID 004BB906 CTI
      13:04:46 - JLink: [0][1]: E0043000 CID B105900D PID 001BB908 CSTF
      13:04:46 - JLink: I-Cache L1: 32 KB, 512 Sets, 32 Bytes/Line, 2-Way
      13:04:46 - JLink: D-Cache L1: 32 KB, 256 Sets, 32 Bytes/Line, 4-Way

      My set-up:
      • SystemView v5.52 MacOS Sonoma
      • J-Link 9.2, J-link configurator says the firmware is up to date.
      • Connected via 20-pin JTAG connector
      • Running a very basic C++ FreeRTOS app on the RT1176 (using NXP RT1170EVK), with 2 tasks and 1 ISR. Tasks have plenty of memory.
      • FreeRTOS v10.5, manually patched using 10.4 patch code.
      • Source code included in build:
        • "${ProjDirPath}/../systemview/SEGGER/SEGGER_RTT_printf.c"
        • "${ProjDirPath}/../systemview/SEGGER/SEGGER_RTT.c"
        • "${ProjDirPath}/../systemview/SEGGER/SEGGER_SYSVIEW.c"
        • "${ProjDirPath}/../systemview/SEGGER/SEGGER_RTT_ASM_ARMv7M.S"
        • "${ProjDirPath}/../systemview/Sample/FreeRTOSV10.4/SEGGER_SYSVIEW_FreeRTOS.c"
        • "${ProjDirPath}/../systemview/Sample/FreeRTOSV10.4/Config/Cortex-M/SEGGER_SYSVIEW_Config_FreeRTOS.c"

      • Include dirs included in build:
        • "${ProjDirPath}/../systemview/SEGGER"
        • "${ProjDirPath}/../systemview/Config"
        • "${ProjDirPath}/../systemview/Sample/FreeRTOSV10.4"

      • Application running from RAM
      • #define SYSVIEW_RAM_BASE (0x20240000), which is SRAM_OC2
      • SEGGER_SYSVIEW_Conf(); and SEGGER_SYSVIEW_Start(); both called at start of main

      What I have tried:

      • Following SystemView Guide, variosu forum post suggestions, Wiki page
      • Adjusting SYSVIEW_RAM_BASE
      • Running app from flash
      • Using un-patched FreeRTOS
      • Enabling cycle counting on M7
      • #define configUSE_TRACE_FACILITY 1
      • #define INCLUDE_xTaskGetIdleTaskHandle 1
      • Checked example FreeRTOS v1.4 SystemView code for any obvious issues

      I must be missing something fairly basic, but I feel like I've followed the instructions to the letter. Any help greatly appreciated.

      Thanks, Matt