[SOLVED] No function names on MacOS

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] No function names on MacOS

    I've been trying to evaluate SystemView for a client. So far, I've been unable to fully use the SystemView application; everything seems to work fine, but functions are called function #xxx. I enter a function #167, then enter a function #43, and so on. I've followed a few tutorials on how to be able to send the data, but never managed to get it up and running. Yesterday, I had to whip out the Windows laptop for some firmware upgrades, and surprisingly, everything worked immediately. The function names were there, and when I opened up an example, the function names were there too (this isn't the case on MacOS; even on the examples, there is no function name). Both systems are running v3.52a.
    Does anyone have something similar?
  • Hi,

    Thank you for your inquiry.

    At first glance it seems like the description file could not be found when using MacOS.

    Are there any messages regarding this in the log window?
    In case it cannot be found the expected path should be written there, so you may simply copy the file to the expected location.

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.
  • And that has indeed fixed it.

    The log looked like this:

    Source Code

    1. 17:24:08 - Loading /Applications/SEGGER/SystemView_V352a/Sample/FS_DeviceActivity.SVDat
    2. 17:24:08 - TRACE START Event recorded.
    3. 17:24:08 - Warning: No description file found for embOS.
    4. 17:24:08 - Warning: Description files can be stored at /Users/jlangbridge/.config/SEGGER
    5. 17:24:08 - Warning: No description file found for emFile.
    6. 17:24:08 - Warning: Description files can be stored at /Users/jlangbridge/.config/SEGGER

    All of the files are available in the installation folder (Applications/SEGGER/SystemView/Description), but SystemView doesn't look for them in that folder. Instead, it looks at my home folder (/Home/<user>/.config/SEGGER/). The only file present was .SEGGER SystemView.ini which makes no reference to any files other than previously opened files. Once I copied the files over, it's all good, and I finally understand what my board is doing.

    Many thanks!