[SOLVED] SES 8.10b: scanops.c:(.text.libc.sscanf+0x22): undefined reference to `__SEGGER_RTL_vfscanf'

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SES 8.10b: scanops.c:(.text.libc.sscanf+0x22): undefined reference to `__SEGGER_RTL_vfscanf'


    I've upgraded SES from (for ARM 7.30) to 8.10b. I now get the following error at the final build step for both Debug and Release mode:

    scanops.c:(.text.libc.sscanf+0x22): undefined reference to `__SEGGER_RTL_vfscanf'

    How can I resolve this error?

    Thanks in advance.

    Kind regards,

    Remco Poelstra
  • Hi,

    I have the same problem.

    Segger v7.32 works fine.

    Segger v8.10b give me this error

    Linking HMI.elf
    C:/Program Files/SEGGER/SEGGER Embedded Studio 8.10b/lib/libc_v7em_fpv4_sp_d16_hard_t_le_eabi_balanced.a(prinops.o): in function `vfprintf_l':
    prinops.c:(.text.libc.vfprintf_l+0x5c): undefined reference to `__SEGGER_RTL_vfprintf'
    Build failed
    Build failed

    I returned back to version 7

    Kind Regards
  • Hello,

    Thank you for your inquiry.
    Such an issue is not known to us.
    Do you see the same behaviour with the latest Embedded Studio v8.10d?
    If yes, could you provide an example project for reproduction?

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.
  • Hi,

    I think this issue is resolved.
    While trying to build a reproducible example and going back and forth between v7.30 and v8.10d I've somehow managed to clear the error.
    The original project now compiles fine under v8.10d.