[SOLVED] Issue about 'old firmware'

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Issue about 'old firmware'

    I'm using J-link for a RISC-V application, when the commander connects to the target, it prompts some strange hint 'RISC-V: The connected J-Link (S/N 851005533) uses an old firmware module V1 with known problems / limitations.' but the firmware is up-to-date, please help me know what it means and what limitations are they?
    Log when connecting to target:

    SEGGER J-Link Commander V7.94f (Compiled Jan 17 2024 15:36:28)
    DLL version V7.94f, compiled Jan 17 2024 15:35:18

    Connecting to J-Link via USB...O.K.
    Firmware: J-Link V11 compiled Dec 4 2023 10:22:45
    Hardware version: V11.00
    J-Link uptime (since boot): 0d 00h 00m 11s
    S/N: 851005533
    License(s): RDI, FlashBP, FlashDL, JFlash, GDB
    USB speed mode: High speed (480 MBit/s)

    Type "connect" to establish a target connection, '?' for help
    Please specify device / core. <Default>: HPM5301XEGX
    Type '?' for selection dialog
    Please specify target interface:
    J) JTAG (Default)
    S) SWD
    T) cJTAG
    Device position in JTAG chain (IRPre,DRPre) <Default>: -1,-1 => Auto-detect
    Specify target interface speed [kHz]. <Default>: 4000 kHz
    Device "HPM6364XPAX" selected.

    Connecting to target via JTAG
    ConfigTargetSettings() start
    ConfigTargetSettings() end - Took 472us
    TotalIRLen = 5, IRPrint = 0x01
    JTAG chain detection found 1 devices:
    #0 Id: 0x1000563D, IRLen: 05, RV32
    Debug architecture:
    RISC-V debug: 0.13
    AddrBits: 7
    DataBits: 32
    IdleClks: 7
    Memory access:
    Via system bus: Yes (8/16/32-bit accesses are supported)
    Via ProgBuf: Yes (8 ProgBuf entries)
    Via abstract command (AAM): May be tried as last resort
    DataBuf: 4 entries
    autoexec[0] implemented: Yes
    Detected: RV32 core
    RISC-V: The connected J-Link (S/N 851005533) uses an old firmware module V1 with known problems / limitations.
    Temp. halting CPU for for feature detection...
    HW instruction/data BPs: 2
    Support set/clr BPs while running: No
    HW data BPs trigger before execution of inst
    CSR access via abs. commands: Yes
    Compressed instruction support: Yes
    Feature detection done. Restarting core...
    BG memory access support: Via SBA
    Memory zones:
    Zone: "Default" Description: Default access mode
    RISC-V identified.
  • Hi,
    You can look them up in the release notes.
    You can search for the term: "RISC-V: Firmware module version" for differences and compare them.

    Please note that the list will grow further with time, as features are constantly added and issues constantly resolved.

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.