[SOLVED] Sleep/WFI disconnects

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Sleep/WFI disconnects

    I have a project in SES 8.10b that disconnects when I hit the wait for interrupt command. It pops up immediately with "JLINK ERROR"

    Part: MSPM01306
    Compiler: SEGGER
    Linker: GNU
    OS: Mac OS 14.2.1
    System: Macbook Pro M1 Max

    If I use RTT Viewer, the JLINK does not disconnect and it reconnects when an interrupt source wakes the part.

    Is there a setting I need for the JLINK to wait for reconnect when the device wakes up from an interrupt source?

    I have tried with and without the STANDBY call, and it still disconnects.

    C Source Code

    1. #ifndef DEBUG
    2. //DL_SYSCTL_setPowerPolicySTANDBY0();
    3. __WFI();
    4. #endif
  • Hello,

    Thank you for your inquiry.
    Sleep mode debugging is pretty hit or miss and it is implementation defined by the silicon vendor what theoretically works or not.
    The error most likely happens because ES is trying to read some memory from the target or checking some target status. If the target does not respond -> Error.

    Here is a J-Link article that explains some potential workarounds but there is no guarantee that you will find a reliable debug setup:

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.