[SOLVED] Wrong CPU type for CORTEX_R52 in the jlink script

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Wrong CPU type for CORTEX_R52 in the jlink script

    Dear Segger Experts,

    The Jlink would report error when I set the CPU = CORTEX_R52.

    If I want to support Cortex-R52, how to the CPU value in the Jlinkscript?

    Thanks in advance!
    • err.png

      13.26 kB, 1,223×79, viewed 149 times
  • Hi Gavin,
    I had a quick look at this. CORTEX_R52 is currently not pre-defined.
    I will forward this internally.

    For now you can use the magic value instead:

    Source Code

    1. JLINK_CPU = 0x1404FFFF
    JLINK_CPU and CPU refer to the same variable.

    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.