[SOLVED] Hardfault Error While Debugging in Systemview

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Hardfault Error While Debugging in Systemview

    The SystemView is running properly when I don't integrate TouchGFX into STM32CubeIDE. However, when I integrate TouchGFX into my code, I'm able to debug with ST-Link. On the other hand, when I use J-Link, I'm getting a hardfault error while debugging. Below, I have attached screenshot .
    • Screenshot (192).png

      317.51 kB, 1,920×1,080, viewed 519 times
    • Screenshot (193).png

      186.59 kB, 1,920×1,080, viewed 511 times
    • Screenshot (194).png

      207.1 kB, 1,920×1,080, viewed 527 times
  • Hello,

    Thank you for your inquiry.
    The screenshots do not show SystemView running. Are you sure you are in the right subforum?
    ST-Link is also not compatible to SystemView, so not sure why you compare these.

    Could you clarify what you are doing and what is working and what not? From your OP this is not clear.

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.