[SOLVED] JlinkRemoteServer cannot connect to Jlink, "Failed to put socket into listening state"

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] JlinkRemoteServer cannot connect to Jlink, "Failed to put socket into listening state"

    I am trying to use JlinkRemoteServer on Windows, and when I launch the software it says, "Failed to put socket into listening state."

    I am running v7.92b of the JLink software toolchain. I just recently purchased this JLink, and it is the base model.

    I have the settings as the default of port 19020 and USB for the connection. I have unplugged and plugged in the jlink more times than I can count.

    This was working before, and then this would occassionally happen. After a Windows reboot, it would usually be fine. Now it seems to happen all the time.

    Does anyone know something I could try?
  • Hi,

    we received you inquiry via our ticket system and responded there already.
    Please refrain from contacting us via multiple channels in parallel - it causes additional workload on our end.
    Additionally, one of the channels may end up with less information than the other.

    J-Link Remote Server's error message "Failed to put socket into listening state." indicates that
    another process on your machine has opened a listener socket on the same port that J-Link Remote Server tries to open.

    This may be another instance of J-Link Remote Server started before,
    or any other process that decides to listen on port 19020.

    In your case, "a windows svhost process" was blocking port 19020.


    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.