mDNS resolution issue from Android phone

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • mDNS resolution issue from Android phone

      I tried to get a working mDNS resolution for webserver.
      I modified offical demo for board Nucleo STM32H743ZI.
      I actually just added mDNS to IP_WebserverSample from IP_MDNS_ServerSample.
      mDNS resolution is working properly on windows 10 - webpage is loaded correctly in google chrome using mdns name.
      Unfuortuenatly that is not the case for android phone (Galaxy S21 Ultra - ONE UI 5.1, Android 13).
      I am aware that android didn't had a mdns resolution until recently.

      To make sure if the mdns resolution works properly on my phone I tried some other devices with mdns server which I have on the local network.
      The mdns worked for all.
      I also analysed mdns packets with wireshark.
      I found out that request from android and response from board is sent:
      I would be very glad if you could test this.