[SOLVED] Reset when attaching to running target

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Reset when attaching to running target

    This is a relatively new problem for me, but it is very annoying. I'm running SEGGER Embedded Studio for ARM V6 with the free license from Nordic. I'm on an Intel iMac Core i7.

    It's always tricky debugging a running Bluetooth application in the debugger because Nordic has their own watchdog in their BT stack, so you really can't step through code. But every once in a while I really just need to see data, so I attach my running application to the debugger and use the Target:Attach Debugger option to attach to my running target. Then I hit the pause button so I can look at variables.

    For some reason, every time I attach the debugger my target resets and I lose all the data. This was not a problem in the past, so I think there must be some setting somewhere that got changed in the last update I did.

    Any clues would be welcome.
  • Hello,

    Thank you for your inquiry.
    Generally we recommend to use the latest Embedded Studio version where possible as only the latest version will be supported.

    Also I recommend to check out monitor mode debugging. Sounds like this is what you are looking for:

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.