[SOLVED] Use J-Link interface on STM32H723-ZG

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Use J-Link interface on STM32H723-ZG


    I have just bought a NUCLEO STM32H723-ZG board and wanted to use a J-Link connection for Tracealayzer (percepio.com/tracealyzer/trace…cealyzer-for-zephyr-rtos/).

    I have then understood a need to uprade the firmware to add a J-Link interface. I have followed these steps: segger.com/products/debug-prob…j-links/st-link-on-board/.

    Everything is ok until last step.

    STLinkReflash tool ends up with Error "Cannot find an ST Link" (see error.png attached file).

    However, the STLink is detected by Windows (see ST_Link.png attached file)

    My system configuration is the following:

    - Windows 10
    - STLinkReflash_190812
    - en.stsw-link009
    - JLink_Windows_V788e_x86_64

    Any help or clue would be greatly appreciated .

    Best Regards,

    • ST_Link.png

      6.58 kB, 309×189, viewed 74 times
    • error.png

      10.97 kB, 1,012×319, viewed 148 times
  • This board has an ST-LINK V3 that is not supported by the conversion utility.

    You need to connect an external J-Link to the board.
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.