[SOLVED] SEGGER_SYSVIEW_PrintfHost and uint32 (bug?)

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] SEGGER_SYSVIEW_PrintfHost and uint32 (bug?)


    The SEGGER_SYSVIEW_PrintfHost line in one of my project tasks should print out an integer in the System View terminal window. It does not. It prints "starting iter r" everytime (see attached screen shot).

    Am I somehow formatting wrong?

    Source Code

    1. void TaskB( void* argument )
    2. {
    3. uint32_t counter = 0;
    4. while(1)
    5. {
    6. counter++;
    7. SEGGER_SYSVIEW_PrintfHost("starting iter %u", counter);
    8. vTaskDelay(StmRand(10,25));
    9. lookBusy(StmRand(250000, 750000));
    10. }
    11. }
    Display All

    I'm using STM32CubeIDE 1.12.1 and System View v3.50a. Working on a Nucleo STM32F767ZI board.
    • snip.jpg

      46.58 kB, 477×344, viewed 474 times

    The post was edited 1 time, last by relayman357: I tested with int32 and it exhibits the same problem. ().

  • Hello,

    Thank you for your inquiry.
    The reported behaviour is reproducible and will be fixed.

    As a workaround for now simply place any character behind the %u.

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.