[SOLVED] cannot update jlink EDU firmware to V10

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] cannot update jlink EDU firmware to V10


    I'm using JLink EDU firmware V9.30 and I need to update at least to the V10. I've found this version (JLink_V11.bin) in the firmware folder op/SEGGER/JLink_V780d/Firmwares
    However, I'm not able to update the firmware using the SEGGER J-Link Configuration software. The output Log message is

    Not updated, probe/ programmer firmware is already up to date

    Here's the JLink EDU information

    Product = J-Link EDU V9.30
    Nickname =
    SN = 269301238
    USB = SN 269301238
    HostFW = 2021 May 7 16:26
    EmuFW = 2021 May 7 16:26

    Please, how can I update this?


    The post was edited 1 time, last by gschelotto ().

  • V9 and V10 are different hardware versions.
    You cannot make a V9 to a V10 hardware via a firmware update…
    There is even a different MCU on the V10 hardware…
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.