J-Scope RTT SamplingPeriod

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • J-Scope RTT SamplingPeriod

      Setup: J-Scope 7.59a beta, J-Link Edu V9, STM32L431, Linux

      I have a loop generating new data every 1ms. I checked this timing with a scope and pin toggle.
      Within this loop a block of RTT without timestamps is sent, works fine so far.
      J-Scope shows this data but the time between two data points is shown and logged as 100µs.
      I noticed that there is a parameter "SamplingPeriod" in the .jscope config file, default is 100. I changed it to 1000 (1ms), but this had no effect.

      Does anyone has a solution for this? (Except for sending timestamps which I try to avoid to reduce data.)
      Is it due to RTT? The "IsAutoConfig" setting gets ignored as well.

      Btw, thanks for all the improvements in J-Scope recently!

      Best, Michael
    • Hello Michael,

      when RTT without timestamps is used, a block of samples without any timestamps arrives for J-Scope at the same time. Therefore there is no real way for J-Scope to know the real time difference between any two samples.

      Because of this, J-Scope just assumes a time difference of 100 us. If you want to have timestamps that reflect the real situation, we recommend using HSS or better RTT with timestamps.

      Best regards,
      Matthias
      Please read the forum rules before posting.

      Keep in mind, this is *not* a support forum.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support you can contact us via our support system: segger.com/ticket/

      Or you can contact us via e-mail.