Appwizard aplication running in envision kit RX65N

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Appwizard aplication running in envision kit RX65N

      Hello everyone,

      I was working on an aplication using Appwizard and now i finish that part, now i'm trying to upload to envision kit RX65N but it's not clear enough how to do that. Found a document about the integration between Appwizard and RA family devices, but it's not working, tried following the steps but there is one configuration about GNU ARM C COMPILER that is not in e2 studio. Someone can help me with some guidance, tutorials or examples that can use to solve my problem. any help is appreciated :)
    • Hi,

      If you are using the AppWizard which is provided by Renesas you can select a BSP for the RX65N from within the AppWizard.

      Go to Project -> Edit Options

      In the upcoming dialog you can select a BSP for the RX65N Envision Kit.

      The BSP will be located in the AppWizard project directory in the "Target" folder: c:\AppWizard\<ProjectName>\Target\

      This can be opened with e²Studio.

      Regards,
      Sven
      Please read the forum rules before posting.

      Keep in mind, this is *not* a support forum.
      Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
      Should you be entitled to support you can contact us via our support system: segger.com/ticket/

      Or you can contact us via e-mail.
    • New

      Hi,

      I have selected the BSP as recommended but in the project directory is no folder named target, i tried saving in another path using save as, and also tried export and save, but target folder that you mention doesn't seem to appear anywhere, is there something i can do?

      Regards.
      Images
      • image_2021-11-24_080758.png

        41.51 kB, 756×422, viewed 10 times
    • New

      update!

      i managed to create/find the target folder, but with demos like weather forecast runs just fin on the envision kit, but with my program the only thing it does is blink the screen once. Made another application with 3 elements and goes relatively fine (there are some transparencies) so i made a copy of my project, delete everything and replicate the application with 3 buttons and get the same blinking problem, what could be the problem? is something wrong with my original application?