[SOLVED] J-Link: Could not establish a connection to target

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J-Link: Could not establish a connection to target

    I am having difficulty using a j-link mini to flash the bootloader on a Seeed Arch Mix development board (MCIMXRT1052QSPI).

    I am a hobbyist that is fairly new to working on hardware.

    I am following directions provided by Seeed to update the bootloader to Arduino using J-Link.

    I get to the point of flashing the new bootloader in J-Flash and it fails to connect to the target board.

    Here is the full log from J-Flash.

    Application log started
    - J-Flash V7.22b (J-Flash compiled Jun 17 2021 17:23:09)
    - JLinkARM.dll V7.22b (DLL compiled Jun 17 2021 17:22:49)
    Reading flash device list [C:\Program Files (x86)\SEGGER\JLink\ETC/JFlash/Flash.csv] ...
    - List of flash devices read successfully (451 Devices)
    Reading MCU device list ...
    - List of MCU devices read successfully (8512 Devices)
    Creating new project ...
    - New project created successfully
    Opening data file [C:\Users\bcc\Documents\Arduino\Arch Mix\bootloader.hex] ...
    - Data file opened successfully (39360 bytes, 1 range, CRC of data = 0x805A496A, CRC of file = 0xB416A8BD)
    Connecting ...
    - Connecting via USB to probe/ programmer device 0
    - Updating firmware: J-Link EDU Mini V1 compiled Jun 17 2021 16:46:54
    - Replacing firmware: J-Link EDU Mini V1 compiled Feb 4 2021 13:01:48
    - Waiting for new firmware to boot
    - New firmware booted successfully
    - Probe/ Programmer firmware: J-Link EDU Mini V1 compiled Jun 17 2021 16:46:54
    - Device "MCIMXRT1052QSPI" selected.
    - Target interface speed: 4000 kHz (Fixed)
    - VTarget = 0.000V
    - ERROR: Failed to connect.
    Could not establish a connection to target.

    I believe my issue is in my wiring between the j-link and the Arch Mix board.

    The wiki instructions states:
    Connect J-Link's SWD pins to Arch Mix's SWD Pins.
    DIO to DIO
    CLK to CLK
    GND to GND

    I used the provided j-link ribbon cable to make a small harness that allows me to connect the j-unit to a breadboard for these 3 connections.
    I checked the pinout on both devices and believe I have them mapped correctly.
    I have verified continuity in the connections between the boards.

    J-Link Ribbon Pin #2; SWDIO ==> Arch Mix DIO Pin J420
    J-Link Ribbon Pin #3; GND ==> Arch Mix GND Pin J421
    J-Link Ribbon Pin #4; SWCLK ==> Arch Mix CLK Pin J419

    Is there anything obvious that I am missing?
    Is the "VTarget = 0.000V" an issue?
    Do I need to connect the j-link VTRef pin to 3.3v on the board?

    Carmon Colvin
  • I found my problem, it was the missing VTarget value.

    After connecting J-Link Ribbon Pin #1; VTref ==> Arch Mix 3v3 Pin J422 I was able to flash the bootloader.

    I was hesitant to make the connection since it was not in the instructions and I know just enough to be dangerous with development boards.
  • Hi,
    Good to hear that you are up and running again.

    Since the issue is resolved, we will close this thread.

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.