[SOLVED] Build problem at STM32F4 Cube Package 1.26.0

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Build problem at STM32F4 Cube Package 1.26.0

    Hi guys

    I was using STM32F4 Cube package 1.25.0 with SEGGER_SYSVIEW_FreeRTOS.c and other segger files and a few days ago, I replaced it with a new package 1.26.0 and met the error below.

    "C:/Users/ckim/workspace/STM32Cube_FW_F4_V1.26.0/Middlewares/Third_Party/FreeRTOS/Source/queue.c: In function 'prvNotifyQueueSetContainer':
    ../../../Src/Core/Logs/SEGGER_SYSVIEW_FreeRTOS.h:223:195: error: 'xCopyPosition' undeclared (first use in this function)
    #define traceQUEUE_SEND( pxQueue ) SEGGER_SYSVIEW_RecordU32x4(apiID_OFFSET + apiID_XQUEUEGENERICSEND, SEGGER_SYSVIEW_ShrinkId((U32)pxQueue), 0u, 0u, xCopyPosition)"

    It looks FreeRTOS V1.3.0 (included at 1.26.0 package) doesn't use xCopyPosition anymore.
    Do you have any idea how to resolve this issue?
  • Hi,

    Thank you for your inquiry.
    Not all FreeRTOS versions are backwards compatible.
    So it is possible that if you update your FreeRTOS Sources SystemView will no longer work. Which is why we supply different patch files for different FreeRTOS versions.
    A Guide with the patch files can be found here:

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.