[SOLVED] Debug session quits by itself

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] Debug session quits by itself


    i am trying to debug a project on a STM32H753VIT. The Ozone version ist V3.22e. The debugger is a J-Link Pro.
    I can download the program without any problems. But when i start the program, i get the following error message after a few seconds: CPU_REG_Set(): Register 0 is already marked as valid.
    After that i can not resume the debug session.

    Under which conditions Ozone pops up these error message? What do i have to check to solve the problem?

    Thank you for your help.
  • Hello,

    We received this inquiry via our support system in parallel so this thread will be closed now.
    The solution was that the target application was using a __WFI instruction during debug which caused this issue.
    Generally we do not recommend to try to debug low power modes if possible to avoid such follow up issues.

    For more information see here:

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.