[SOLVED] J LINK OB on nrf52840 development board, MSD read only

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [SOLVED] J LINK OB on nrf52840 development board, MSD read only


    I have recntly purchased a Nordic Semiconductors nrf52840 development board.
    I am having issues with the J Link OB MSD. When connected to LINUX Ubuntu 20.04 LTS which is running on a VM (Mac osx), the drive appears as readonly.
    I have tried 3 different VM's. VMWare fusion, Parallels and Virtual Box.

    If i connect the development board directly to Mac Book, Win 10 PC or LINUX VM hosted on Win 10 with VMWare it works OK.
    The problem only occurs when running LINUX hosted on MAC OSX VM.

    Does anybody have any suggestions on how to fix this.

    Thanks for you support.
  • Hi,
    Thank you for your inquiry.

    There are no issues known to us regarding this.

    As this works on native Linux and all other platforms and
    the issue only appears on Linux + MAC VM we would suspect that this is a general
    VM / configuration issue.

    We will put this on our internal list and see if we can reproduce this on occasion.

    Best regards,
    Please read the forum rules before posting.

    Keep in mind, this is *not* a support forum.
    Our engineers will try to answer your questions between their projects if possible but this can be delayed by longer periods of time.
    Should you be entitled to support you can contact us via our support system: segger.com/ticket/

    Or you can contact us via e-mail.